Error: Could not stat() command file '/usr/local/nagios/var/

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

Error: Could not stat() command file '/usr/local/nagios/var/

Postby arnob » Wed Jul 28, 2021 11:09 am

Hi, I'm a newbie. I'm getting the error as below in nagios core UI. This error isn't new and is well known.

error screenshot

Platform: RHEL 8 (Server hosted in AWS EC2)

I have gone through

Code: Select all
[root@Nagios-Master ~]# ll /usr/local/nagios/var/rw/
total 0
prw-rw----. 1 nagios nagcmd 0 Jul 27 19:14 nagios.cmd
srw-rw----. 1 nagios nagcmd 0 Jul 27 19:14 nagios.qh

[root@Nagios-Master ~]# grep nag /etc/group
[root@Nagios-Master ~]#

I have already tried executing the commands as below:
Code: Select all
usermod -G nagcmd nagios
usermod -G nagcmd apache
service httpd restart
service nagios restart

Also the files under /usr/local/nagios/var/rw/ disappears if nagios is stopped and reappears when nagios is started back up. Maybe this is an expected behaviour.

Nothing has helped resolved this issue so far. Is there anything else I could try?

By the way I have also tried providing full permission:
Code: Select all
chmod 777 nagios.cmd
. Still no luck :cry:

Thanks in Advance! I appreciate your help and feedbacks.
Posts: 1
Joined: Wed Jul 28, 2021 10:32 am

Return to Community Support

Who is online

Users browsing this forum: No registered users and 27 guests