Page 1 of 1

Regarding Update "Apply configurations"

PostPosted: Wed Oct 06, 2021 9:11 pm
by ashok.verma
I have deleted host & Services from Nagios Xi -ISKVVSP01

But when we apply configuration using CCM it is showing below error..
-Error: Invalid max_check_attempts value for host 'ISKVVSP01'
Error: Could not register host (config file '/usr/local/nagios/etc/hosts/ISKVVSP01.cfg', starting on line 16)

i have already check -/usr/local/nagios/etc/hosts & /usr/local/nagios/etc/services. No ISKVVSP01.cfg file available inside this location.

Please help us
...

Re: Regarding Update "Apply configurations"

PostPosted: Thu Oct 07, 2021 3:14 pm
by gormank
Have a look at max_check_attempts for the host in CCM.

Re: Regarding Update "Apply configurations"

PostPosted: Thu Oct 07, 2021 6:17 pm
by mcapra
If you're confident all objects associated with the ISKVVSP01 host have been deleted, you could try a "delete, write, verify":

tgriep wrote:Login to the XI GUI and go to the Core Config Manager

Under "Tools", click "Write Config Files" or if you are running a newer versions of XI, The menu is called "Config File Management"
Click on the "Write" button, then the "Delete" button then click the "Write" button and then the "Verify" button.
If you get any errors, resolve them and click on the "Delete" button, "Write", "Verify" until all of the errors are resolved.
Click the Apply Configuration link and click the "Apply Configuration" button after ALL of the errors are resolved.

Re: Regarding Update "Apply configurations"

PostPosted: Wed Oct 13, 2021 5:03 pm
by benjaminsmith
HI ashok.verma,

Were you able to get it worked out? Let us know when you have a minute.

Thanks,
Benjamin
Nagios Support Team

Re: Regarding Update "Apply configurations"

PostPosted: Wed Oct 13, 2021 9:08 pm
by ashok.verma
Thanks , it is working fine