startup problem, not with main page, but second page

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

startup problem, not with main page, but second page

Postby rkiddy » Tue Oct 12, 2021 12:07 pm

I have installed nagios on my ubuntu system (Ubuntu 20.04.3 LTS). I have tried to put in the integration with apache. I think I have it almost right. When I go to http://opencalaccess.org/nagios, it asks me to log in and takes me to the correct page.

But if I click on a link on that page, I get: Error: Could not read object configuration data!

What have I got wrong here? Any suggestions?

cheers - ray

All contents of /usr/local/nagios are owned by the nagios user except for:
Code: Select all
# find /usr/local/nagios -ls | grep root
   524387      4 drwxr-xr-x   8 root     root         4096 Sep 30 13:45 /usr/local/nagios
   524827      4 -rw-r--r--   1 root     root           50 Sep 30 13:45 /usr/local/nagios/etc/htpasswd.users
   524824      4 drwxr-xr-x   3 root     root         4096 Sep 30 13:38 /usr/local/nagios/var/spool


When I access the front page and then click on the Services link, I get this in my apache access.log:

Code: Select all
24.130.158.80 - nagiosadmin [12/Oct/2021:10:04:15 -0700] "GET /nagios/ HTTP/1.1" 200 883 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:93.0) Gecko/20100101 Firefox/93.0"
24.130.158.80 - nagiosadmin [12/Oct/2021:10:04:16 -0700] "GET /nagios/side.php HTTP/1.1" 200 1406 "http://opencalaccess.org/nagios/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:93.0) Gecko/20100101 Firefox/93.0"
24.130.158.80 - nagiosadmin [12/Oct/2021:10:04:16 -0700] "GET /nagios/main.php HTTP/1.1" 200 3227 "http://opencalaccess.org/nagios/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:93.0) Gecko/20100101 Firefox/93.0"
24.130.158.80 - nagiosadmin [12/Oct/2021:10:04:17 -0700] "GET /nagios/cgi-bin/statusjson.cgi?query=programstatus HTTP/1.1" 200 23675 "http://opencalaccess.org/nagios/main.php" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:93.0) Gecko/20100101 Firefox/93.0"
24.130.158.80 - nagiosadmin [12/Oct/2021:10:04:19 -0700] "GET /nagios/cgi-bin/status.cgi?host=all HTTP/1.1" 200 1314 "http://opencalaccess.org/nagios/side.php" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:93.0) Gecko/20100101 Firefox/93.0"


Code: Select all
# /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

Nagios Core 4.4.6
Copyright (c) 2009-present Nagios Core Development Team and Community Contributors
Copyright (c) 1999-2009 Ethan Galstad
Last Modified: 2020-04-28
License: GPL

Website: https://www.nagios.org
Reading configuration data...
   Read main config file okay...
   Read object config files okay...

Running pre-flight check on configuration data...

Checking objects...
   Checked 8 services.
   Checked 1 hosts.
   Checked 1 host groups.
   Checked 0 service groups.
   Checked 1 contacts.
   Checked 1 contact groups.
   Checked 24 commands.
   Checked 5 time periods.
   Checked 0 host escalations.
   Checked 0 service escalations.
Checking for circular paths...
   Checked 1 hosts
   Checked 0 service dependencies
   Checked 0 host dependencies
   Checked 5 timeperiods
Checking global event handlers...
Checking obsessive compulsive processor commands...
Checking misc settings...

Total Warnings: 0
Total Errors:   0

Things look okay - No serious problems were detected during the pre-flight check
rkiddy
 
Posts: 1
Joined: Fri Oct 08, 2021 3:49 pm

Return to Community Support

Who is online

Users browsing this forum: milovancevic3 and 22 guests