We've moved to a new support system!

The Nagios Answer Hub is a place where you can get help with technical questions from our experts. There, you can quickly open tickets and join discussion boards.

Request Nagios Answer Hub access here: https://info.nagios.com/answer-hub-access-new-users

After completing the access form, you will be given access to a portal where new tickets can be created. We will keep the old customer forum sections and ticket system available for current cases to be resolved.

Go to the Answer Hub

Unable to monitor esxi hosts

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

Unable to monitor esxi hosts

Postby baron164 » Wed Apr 27, 2022 3:30 pm

I deployed the latest Nagios ova into my VMware environment so I can test it using the 30 day trial license. So far monitoring web sites and windows machines works fine. But I've been unable to add my ESXi hosts into Nagios. I've installed the latest Perl SDK from VMware and I've tried added the hosts into Nagios using the wizard but I just receive "(Service check timed out after 60.04 seconds)" errors. I tried to run the check_vmware_api.pl script manually but that gives me a "CHECK_VMWARE_API.PL CRITICAL - SOAP request error - possibly a protocol issue" error. Can anyone tell me what the issue might be and/or how to fix it?
baron164
 
Posts: 7
Joined: Wed Jun 22, 2016 1:08 pm

Re: Unable to monitor esxi hosts

Postby gormank » Wed Apr 27, 2022 4:07 pm

You could try running checks via the vcenter host rather than the ESX hosts. -D below is the vcenter host.

/usr/local/nagios/libexec/check_vmware_api.pl -H $HOSTNAME$ -u $USER9$ -p $USER10$ --command=cpu --subcommand=usage -w 50% -c 80% -D $USER11$ -C CMV --timeout=15

Other than that I would google the the error message and see what others have done.
gormank
 
Posts: 992
Joined: Tue Dec 02, 2014 12:00 pm


Return to Community Support

Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot] and 21 guests

cron