We've moved to a new support system!

The Nagios Answer Hub is a place where you can get help with technical questions from our experts. There, you can quickly open tickets and join discussion boards.

Request Nagios Answer Hub access here: https://info.nagios.com/answer-hub-access-new-users

After completing the access form, you will be given access to a portal where new tickets can be created. We will keep the old customer forum sections and ticket system available for current cases to be resolved.

Go to the Answer Hub

unable to start nagios with systemctl

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

unable to start nagios with systemctl

Postby mnf59 » Wed May 11, 2022 1:23 am

Hi all, very curious issue, installed Nagios core 4.4.7 on a fresh OEL8 installation, no other applications. Nagios starts on system boot and works fine but if i have to change or add some configurations when i try systemctl restart nagios it seems to start, all processes are up for a while but soon after all processes die. This is on nagios.log, any idea ?
Thanks
Dario

1652250117] LOG VERSION: 2.0
[1652250117] qh: Socket '/usr/local/nagios/var/rw/nagios.qh' successfully initialized
[1652250117] qh: core query handler registered
[1652250117] qh: echo service query handler registered
[1652250117] qh: help for the query handler registered
[1652250117] wproc: Successfully registered manager as @wproc with query handler
[1652250117] wproc: Registry request: name=Core Worker 17492;pid=17492
[1652250117] wproc: Registry request: name=Core Worker 17493;pid=17493
[1652250117] wproc: Registry request: name=Core Worker 17490;pid=17490
[1652250117] wproc: Registry request: name=Core Worker 17491;pid=17491
[1652250118] Caught SIGSEGV, shutting down...
mnf59
 
Posts: 1
Joined: Wed Apr 01, 2020 1:32 am

Re: unable to start nagios with systemctl

Postby sjakie » Wed May 18, 2022 1:48 am

I have exactly the same thing after upgrading to nagios 4.4.7.
hours of searching have brought me an answer finally.
The problem is that someone (from nagios company I Guess) has updatet a core component which checks for the Nagios updates, it has to do something with enabling SSL in the update request.

In Your nagios.cfg there is an option : check_for_updates = 1, you should change that in check_for_updates = 0.
Now you can start nagios as usual, the only thing is that you have to look for nagiosupdates yourself.
sjakie
 
Posts: 1
Joined: Tue May 17, 2022 4:11 pm

Re: unable to start nagios with systemctl

Postby CarolBrusteredman » Thu May 19, 2022 6:32 am

I created this file:

sudo vi /etc/systemd/system/nagios.service
and added the following:

[Unit]
Description=Nagios
BindTo=network.target


[Install]
WantedBy=multi-user.target

[Service]
User=nagios
Group=nagios
Type=simple
ExecStart=/usr/local/nagios/bin/nagios /usr/local/nagios/etc/nagios.cfg
Then the following:

sudo systemctl enable /etc/systemd/system/nagios.service
sudo systemctl start nagios
sudo systemctl restart nagios
CarolBrusteredman
 
Posts: 5
Joined: Tue Mar 22, 2022 5:50 am


Return to Community Support

Who is online

Users browsing this forum: Google [Bot] and 12 guests