We've moved to a new support system!

The Nagios Answer Hub is a place where you can get help with technical questions from our experts. There, you can quickly open tickets and join discussion boards.

Request Nagios Answer Hub access here: https://info.nagios.com/answer-hub-access-new-users

After completing the access form, you will be given access to a portal where new tickets can be created. We will keep the old customer forum sections and ticket system available for current cases to be resolved.

Go to the Answer Hub

CHECK_NRPE: Error - Could not complete SSL handshake.

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

CHECK_NRPE: Error - Could not complete SSL handshake.

Postby deepakd » Thu May 19, 2022 11:14 am

I am getting issue while configuring the nrpe through xinetd

It gives me

CHECK_NRPE: Error - Could not complete SSL handshake.

I have done below configuration:


# default: on
# description: NRPE (Nagios Remote Plugin Executor)
service nrpe
flags = REUSE
socket_type = stream
port = 5666
wait = no
user = icinga
group = icinga
server = /usr/local/icinga/bin/nrpe
server_args = -c /usr/local/icinga/etc/nrpe.cfg --inetd
log_on_failure += USERID
disable = no
cps = 100 30
per_source = UNLIMITED
instances = UNLIMITED
only_from =

cat /usr/local/icinga/etc/nrpe.cfg|grep allowed
# that are allowed to talk to the NRPE daemon. Network addresses with a bit mask

cat /etc/services |grep 566
nrpe 5666/tcp # Nagios Remote Plugin Executor

I have tried all things mention in link
https://supportmonk.com/2020/09/09/chec ... s%20server.

aslo tried

dont_blame_nrpe=1 in /usr/local/icinga/etc/nrpe.cfg

added the IPs in hosts.allow.

I have tried the below command while installing nrpe:

./configure --prefix=/usr/local/icinga --with-nagios-user=icinga --with-nagios-group=icinga --with-nrpe-user=icinga --with-nrpe-group=icinga --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib/x86_64-linux-gnu

I douubt on network,firewall or openssl for this issue. Is the below version supported the icinga
By the i am running on the nrpe on Ubuntu.

openssl version
OpenSSL 1.1.1f 31 Mar 2020

Can you please help me, what I missed to check.
nrpe cfg on path usr local
(8.02 KiB) Downloaded 18 times
Posts: 1
Joined: Thu May 19, 2022 10:55 am

Return to Community Support

Who is online

Users browsing this forum: No registered users and 27 guests