Page 1 of 1

CHECK_NRPE: Error - Could not complete SSL handshake.

PostPosted: Thu May 19, 2022 11:14 am
by deepakd
I am getting issue while configuring the nrpe through xinetd

It gives me

CHECK_NRPE: Error - Could not complete SSL handshake.


I have done below configuration:

/etc/xinetd/npre

# default: on
# description: NRPE (Nagios Remote Plugin Executor)
service nrpe
{
flags = REUSE
socket_type = stream
port = 5666
wait = no
user = icinga
group = icinga
server = /usr/local/icinga/bin/nrpe
server_args = -c /usr/local/icinga/etc/nrpe.cfg --inetd
log_on_failure += USERID
disable = no
cps = 100 30
per_source = UNLIMITED
instances = UNLIMITED
only_from = 127.0.0.1 10.0.13.82
}


cat /usr/local/icinga/etc/nrpe.cfg|grep allowed
# that are allowed to talk to the NRPE daemon. Network addresses with a bit mask
allowed_hosts=127.0.0.1,10.0.13.82


cat /etc/services |grep 566
nrpe 5666/tcp # Nagios Remote Plugin Executor

I have tried all things mention in link
https://supportmonk.com/2020/09/09/chec ... s%20server.

aslo tried

dont_blame_nrpe=1 in /usr/local/icinga/etc/nrpe.cfg

added the IPs in hosts.allow.

I have tried the below command while installing nrpe:

./configure --prefix=/usr/local/icinga --with-nagios-user=icinga --with-nagios-group=icinga --with-nrpe-user=icinga --with-nrpe-group=icinga --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib/x86_64-linux-gnu

I douubt on network,firewall or openssl for this issue. Is the below version supported the icinga
By the i am running on the nrpe on Ubuntu.

openssl version
OpenSSL 1.1.1f 31 Mar 2020


Can you please help me, what I missed to check.