z

Commercial Support Clients: Clients with support contracts can get escalated support assistance by visiting Nagios Answer Hub. These forums are for community support services. Although we at Nagios try our best to help out on the forums here, we always give priority support to our support clients.

You don't have permission to access /nagios/ on this server

Support forum for Nagios Core, Nagios Plugins, NCPA, NRPE, NSCA, NDOUtils and more. Engage with the community of users including those using the open source solutions.

You don't have permission to access /nagios/ on this server

Postby JamesZimmerman » Mon May 23, 2022 11:44 pm

Hi
I have been trying to setup nagios on mac and it definitely seems pretty easy but I am stuck at this point - I am unable to load the localhost/nagios/ page. I have the right configuration as far as I think.

I have installed PHP and changed the httpd.conf to include "index.php" with index.html. I do not think there is more to it but this small thing is not letting me proceed.

Could anyone shed some light and show me the way?

This is what I have in my configuration file for nagios in hhtpd.conf for apache:

# Nagios stuff

ScriptAlias /nagios/cgi-bin/ "/opt/local/sbin/nagios/"

< Directory "/opt/local/sbin/nagios">

AllowOverride None

Options ExecCGI
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /opt/local/etc/nagios/htpasswd.users
require valid-user
< /Directory>

Alias /nagios "/opt/local/share/nagios"

< Directory "/opt/local/share/nagios">

Options None
AllowOverride AuthConfig
Order allow,deny
Allow from all
< /Directory>

# End Nagios stuff

-- And the error_log file for apache has this:
[error] [client ::1] Directory index forbidden by Options directive omegle shaglevoojio : /opt/local/share/nagios/
JamesZimmerman
 
Posts: 8
Joined: Wed Mar 23, 2022 8:00 am

Return to Open Source Nagios Projects

Who is online

Users browsing this forum: Majestic-12 [Bot] and 9 guests