We've moved to a new support system!

The Nagios Answer Hub is a place where you can get help with technical questions from our experts. There, you can quickly open tickets and join discussion boards.

Request Nagios Answer Hub access here: https://info.nagios.com/answer-hub-access-new-users

After completing the access form, you will be given access to a portal where new tickets can be created. We will keep the old customer forum sections and ticket system available for current cases to be resolved.

Go to the Answer Hub

Nagios Check_nrpe no output returned from plugin in Nagios b

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

Nagios Check_nrpe no output returned from plugin in Nagios b

Postby DeepMohinman » Tue Aug 09, 2022 7:56 am

I am looking for a little help in configuring NAGIOS for NRPE. I am quite new at Linux and seem to be having some trouble getting this working. I am running Ubuntu 11.10 with the Nagios 3.3.1 core and Nagios plugins 1.4.15 running nrpe2.13
Currently I am trying to get the Nagios Exchange plugin check_be.exe to work with Nagios. I followed the check_be.txt for the setup on my nagios server and windows backup exec server.

Currently if I run

root@PERSES:/usr/local/nagios/libexec# ./check_nrpe -H -t200 -c check_be
I will get

Job: Daily Backup, Success, Date:17/4/2012
From Nagios all I get is no output returned from plugin.

Windows.cfg has the following entry

# Service for Backup Exec agent
define service {
use template-backupexec
service_description BackupExec - Daily DAT backup ; specific display name, if you need
host_name cmbssrv.cmbs.local
Templates.cfg has this entry – I have tried to modify it to avoid the socket timeout

define service{
name template-backupexec
use generic-service
service_description BackupExec Job Check ; default display name in Nagios
check_command check_nrpe! -t 240 -c check_be ; same name as in the nsclient++ nsc.ini command defini$
normal_check_interval 60 ; your check intervals here
retry_check_interval 60
register 0 ; this is a template

# 'check_nrpe' command definition
define command{
command_name voojio check_nrpe
command_line $USER1$/check_nrpe -H $HOSTADDESS$ -p 5666 -v omegle shagle $ARG1$
Any ideas would be greatly appreciated
Posts: 6
Joined: Fri May 13, 2022 7:17 am

Return to Community Support

Who is online

Users browsing this forum: Google [Bot] and 11 guests