Nagios Check_nrpe no output returned from plugin in Nagios b

Support forum for Nagios Core, Nagios Plugins, NCPA, NRPE, NSCA, NDOUtils and more. Engage with the community of users including those using the open source solutions.
Post Reply
Posts: 7
Joined: Fri May 13, 2022 7:17 am

Nagios Check_nrpe no output returned from plugin in Nagios b

Post by DeepMohinman »

I am looking for a little help in configuring NAGIOS for NRPE. I am quite new at Linux and seem to be having some trouble getting this working. I am running Ubuntu 11.10 with the Nagios 3.3.1 core and Nagios plugins 1.4.15 running nrpe2.13
Currently I am trying to get the Nagios Exchange plugin check_be.exe to work with Nagios. I followed the check_be.txt for the setup on my nagios server and windows backup exec server.

Currently if I run

root@PERSES:/usr/local/nagios/libexec# ./check_nrpe -H -t200 -c check_be
I will get

Job: Daily Backup, Success, Date:17/4/2012
From Nagios all I get is no output returned from plugin.

Windows.cfg has the following entry

# Service for Backup Exec agent
define service {
use template-backupexec
service_description BackupExec - Daily DAT backup ; specific display name, if you need
host_name cmbssrv.cmbs.local
Templates.cfg has this entry – I have tried to modify it to avoid the socket timeout

define service{
name template-backupexec
use generic-service
service_description BackupExec Job Check ; default display name in Nagios
check_command check_nrpe! -t 240 -c check_be ; same name as in the nsclient++ nsc.ini command defini$
normal_check_interval 60 ; your check intervals here
retry_check_interval 60
register 0 ; this is a template

# 'check_nrpe' command definition
define command{
command_name voojio check_nrpe
command_line $USER1$/check_nrpe -H $HOSTADDESS$ -p 5666 -v omegle shagle $ARG1$
Any ideas would be greatly appreciated
Post Reply