We've moved to a new support system!

The Nagios Answer Hub is a place where you can get help with technical questions from our experts. There, you can quickly open tickets and join discussion boards.

Request Nagios Answer Hub access here: https://info.nagios.com/answer-hub-access-new-users

After completing the access form, you will be given access to a portal where new tickets can be created. We will keep the old customer forum sections and ticket system available for current cases to be resolved.

Go to the Answer Hub

NCPA Agent - AIX 7.2 Works / 7.1 Fails (API Error) [SOLVED]

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

NCPA Agent - AIX 7.2 Works / 7.1 Fails (API Error) [SOLVED]

Postby Eireocean » Tue Aug 16, 2022 3:14 am

Good Day,

As per title, we have installed the NCPA Agent on a handful of AIX Servers. The AIX 7.2 Servers report back fine but the AIX 7.1 Servers fail as follows (working vs not working) :

Code: Select all
# /usr/local/nagios/libexec/check_ncpa.py -H XXXXXX -t 'XXXXXX' -P 5693 -M 'plugins/check_entitlement' -a '-ew=95% -ec=100%'
ENTITLEMENT CRITICAL ent_used=0.16(CRITICAL) ent=0.05 ent_max=1 vcpu_busy=15.94%(CRITICAL) |ent_used=0.16 ent=0.05 ent_max=1 vcpu_busy=15.94

# /usr/local/nagios/libexec/check_ncpa.py -H XXXXXX -t 'XXXXXX' -P 5693 -M 'plugins/check_entitlement' -a '-ew=95% -ec=100%'
UNKNOWN: An error occured connecting to API. (HTTP error: '500 INTERNAL SERVER ERROR')

I have queries the AIX Engineer about the Servers locale / lang setting but they have confirmed it is the same. It was the only reference I have found to date that is similar to this issue.



chmod 755 check_entitlement
Posts: 22
Joined: Tue Oct 11, 2016 2:23 am

Return to Community Support

Who is online

Users browsing this forum: No registered users and 6 guests