Page 1 of 1

NCPA Agent - AIX 7.2 Works / 7.1 Fails (API Error) [SOLVED]

PostPosted: Tue Aug 16, 2022 3:14 am
by Eireocean
Good Day,

As per title, we have installed the NCPA Agent on a handful of AIX Servers. The AIX 7.2 Servers report back fine but the AIX 7.1 Servers fail as follows (working vs not working) :

Code: Select all
# /usr/local/nagios/libexec/check_ncpa.py -H XXXXXX -t 'XXXXXX' -P 5693 -M 'plugins/check_entitlement' -a '-ew=95% -ec=100%'
ENTITLEMENT CRITICAL ent_used=0.16(CRITICAL) ent=0.05 ent_max=1 vcpu_busy=15.94%(CRITICAL) |ent_used=0.16 ent=0.05 ent_max=1 vcpu_busy=15.94

# /usr/local/nagios/libexec/check_ncpa.py -H XXXXXX -t 'XXXXXX' -P 5693 -M 'plugins/check_entitlement' -a '-ew=95% -ec=100%'
UNKNOWN: An error occured connecting to API. (HTTP error: '500 INTERNAL SERVER ERROR')


I have queries the AIX Engineer about the Servers locale / lang setting but they have confirmed it is the same. It was the only reference I have found to date that is similar to this issue.

Regards

SOLUTION

chmod 755 check_entitlement