Disable EH on NAGIOS

This board serves as an open discussion and support collaboration point for Nagios XI. NOTE: Nagios XI customers should use the Customer Support forum to obtain expedited support.

Disable EH on NAGIOS

Postby Nabi » Thu May 17, 2018 9:31 am

Hello,

We have to disable EH on NAGIOS server when NAGIOS got crashed so we can decrease the load on the server.

However, when we do that from the GUI, then after some time it gets enabled on its own. Any idea please what is the reason?

We tried even via the CMD to modify some parameters like:

egrep -i "accept_passive_service_checks|retain_state_information" /usr/local/nagios/etc/nagios.cfg
accept_passive_service_checks=0
retain_state_information=0


Also we were not sure if this really can disable the EH or not as the GUI does not give correct information.

Any help please?

Thanks,

Nabi
Nabi
 
Posts: 9
Joined: Thu Apr 12, 2018 7:13 am

Re: Disable EH on NAGIOS

Postby cdienger » Thu May 17, 2018 3:39 pm

https://assets.nagios.com/downloads/nag ... t_handlers has information on disabling event handlers. Note that you may need to also disable state retention if it is enabled.
User avatar
cdienger
Support Tech
 
Posts: 1276
Joined: Tue Feb 07, 2017 11:26 am

Re: Disable EH on NAGIOS

Postby Nabi » Fri May 18, 2018 3:45 am

Thanks, yeah we were trying with these options, but it seems on the GUI for some reason it gets enabled on its own after some time.
So i am not sure if we still miss some option or we have some other issue..

Thanks,

Nabi
Nabi
 
Posts: 9
Joined: Thu Apr 12, 2018 7:13 am

Re: Disable EH on NAGIOS

Postby cdienger » Fri May 18, 2018 1:00 pm

Can you provide a copy of your nagios.cfg after you've edited it to disable event handlers?
User avatar
cdienger
Support Tech
 
Posts: 1276
Joined: Tue Feb 07, 2017 11:26 am


Return to Nagios XI

Who is online

Users browsing this forum: No registered users and 21 guests