Nagios XI and Nagvis Issues

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Re: Nagios XI and Nagvis Issues

Postby Christopheric1 » Wed Jun 13, 2018 4:46 pm

Here is a new map that I just created:

define global {
alias=TestMap
object_id=0
}

Here are the steps that I take to create my map:

-I create my background with all the nice things on it (customized jpeg with all items typed out so I can add statuses next to them)
-Upload my background jpeg
-change my new map to have the background as the new jpeg in Map Options
-I go to edit and "lock/unlock all" to go into edit mode.
-I add the hosts I want to with my own blocks I created for the "up" "down" "warning" etc.
-I go in and change the "lock/unlock all" back to lock
-I go and turn off the header (I don't want to see it for my NOC screen)

After I do this, If I ever need to edit it for any reason, I can't just go into NagVis and start editing. I have to go to the .cfg file and make "header=0" back to "header=1". When I save it and go back to the map, half of the items are gone that I have put down. I have to try a bunch of things to finally get them to stay on there and not disappear.

I hope that helps a little bit?
Christopheric1
 
Posts: 13
Joined: Wed May 02, 2018 6:06 pm

Re: Nagios XI and Nagvis Issues

Postby tgriep » Thu Jun 14, 2018 8:50 am

The steps that you are doing seem like it should work.

It could be that when you need to edit a map, you should exit the Nagvis interface and go back in in case it is caching the data and removing the items that are in the map.
Also, what are the steps you are doing to turn off the Header?
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
tgriep
Madmin
 
Posts: 6754
Joined: Thu Oct 30, 2014 9:02 am

Re: Nagios XI and Nagvis Issues

Postby Christopheric1 » Thu Jun 14, 2018 9:25 am

Okay, I will try and do that next time, but it doesn't matter if I am in it or not. I watch my NOC screen and they disappear off of that. To lock it, I either go back into the config and change header=0 to header=1 or I try to do it from the menu. Sometimes in the menu it will not work to turn it off and ends up creating that second "Global" piece inside of the cfg.
Christopheric1
 
Posts: 13
Joined: Wed May 02, 2018 6:06 pm

Re: Nagios XI and Nagvis Issues

Postby tgriep » Fri Jun 15, 2018 1:53 pm

If this the option you are editing in the map config file?
Code: Select all
header_menu=1
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
tgriep
Madmin
 
Posts: 6754
Joined: Thu Oct 30, 2014 9:02 am

Re: Nagios XI and Nagvis Issues

Postby Christopheric1 » Fri Jun 15, 2018 2:23 pm

Yes it is
Christopheric1
 
Posts: 13
Joined: Wed May 02, 2018 6:06 pm

Re: Nagios XI and Nagvis Issues

Postby tgriep » Fri Jun 15, 2018 2:50 pm

Thanks for confirming the option you are editing.
Let us know if you have any further questions and if it happens again, can you post the map configuration file with the errors in it?
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
tgriep
Madmin
 
Posts: 6754
Joined: Thu Oct 30, 2014 9:02 am

Re: Nagios XI and Nagvis Issues

Postby Christopheric1 » Mon Jun 18, 2018 8:56 am

I will post errors if I see them, but I haven't through this whole process. The only thing I can help post is the global config after it does its weird thing. Thanks for the help and troubleshooting with me!
Christopheric1
 
Posts: 13
Joined: Wed May 02, 2018 6:06 pm

Re: Nagios XI and Nagvis Issues

Postby tgriep » Mon Jun 18, 2018 1:19 pm

Your welcome.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
tgriep
Madmin
 
Posts: 6754
Joined: Thu Oct 30, 2014 9:02 am

Previous

Return to Nagios Core

Who is online

Users browsing this forum: No registered users and 14 guests