XI 5.5.0 / 5.5.1 - Unable to update components or config wiz

This board serves as an open discussion and support collaboration point for Nagios XI. NOTE: Nagios XI customers should use the Customer Support forum to obtain expedited support.

XI 5.5.0 / 5.5.1 - Unable to update components or config wiz

Postby belvdr » Fri Jul 13, 2018 11:12 am

RHEL 6.10
Nagios XI 5.5.0 or 5.5.1

Since upgrading to 5.5.0 and now 5.5.1, I'm unable to update any components or config wizards. Clicking "Install Updates" shows the pop up and it says "Installation Complete!" but it still says it needs updated.

I also tried manually downloading to my machine then uploading to XI. It says successful, but still no dice.

For components, this is occurring on Operations Center and Proxy Configuration.
For configuration wizards, it is occurring on Windows Server and Windows Desktop.

I've checked filesystem permissions and the nagios group has rw on everything I can find. I checked /usr/local/nagiosxi/var/cmdsubsys.log and saw the following two errors:

Code: Select all
PHP Notice:  unserialize(): Error at offset 0 of 4 bytes in /usr/local/nagiosxi/cron/cmdsubsys.php on line 462
PHP Notice:  Undefined variable: cdir in /usr/local/nagiosxi/cron/cmdsubsys.php on line 516


Full log below:
Code: Select all
PROCESSING COMMAND ID 3675...
PROCESS COMMAND: CMD=1130, DATA=NULL
PHP Notice:  unserialize(): Error at offset 0 of 4 bytes in /usr/local/nagiosxi/cron/cmdsubsys.php on line 462
AUTO UPGRADING CONFIG WIZARDSCMD DATA: Archive:  configwizard-windowsserver.zip
f0122df4ea9eec39d1f13b1fbeb6c6c454576b04
   creating: windowsserver/
  inflating: windowsserver/CHANGES.TXT
  inflating: windowsserver/sanity.sh
  inflating: windowsserver/windowsserver.inc.php
PHP Notice:  Undefined variable: cdir in /usr/local/nagiosxi/cron/cmdsubsys.php on line 516
CHECKING FOR PREINSTALL SCRIPT '/usr/local/nagiosxi/html/includes/configwizards/windowsserver/preinstall.sh'...
PREINSTALL SCRIPT DOES NOT EXIST.
PROCESSING CONFIG FILE /usr/local/nagiosxi/html/includes/configwizards/windowsserver/config.xml
CONFIG FILE DOESN'T EXIST
CHECKING FOR INSTALL SCRIPT '/usr/local/nagiosxi/html/includes/configwizards/windowsserver/install.sh'...
INSTALL SCRIPT DOES NOT EXIST.
CMDLINE=/bin/true
OUTPUT=
RETURNCODE=0
PROCESSING COMMAND ID 3676...
PROCESS COMMAND: CMD=18, DATA=
RECONFIGURING NAGIOSCORE ...
CMDLINE=cd /usr/local/nagiosxi/scripts && ./reconfigure_nagios.sh
No entry for terminal type "unknown";
using dumb terminal settings.

--- reset_config_perms.sh ------------
> Setting CCM script permissions
> Setting script permissions
> Setting special component script permissions
> Setting configuration file/directory permissions
> Setting perfdata directory and RRD permissions
> Setting NOM checkpoint user:group permissions
> + Setting CCM configuration file user:group permissions
> + Setting Recurring Downtime file user:group permissions
> + Setting BPI configuration file user:group permissions
--------------------------------------

--- ccm_import.php -------------------
> Setting import directory: /usr/local/nagios/etc/import/
> Importing config files into the CCM
  No files to import
--------------------------------------

--- ccm_export.php -------------------
> Writing CCM configuration to Nagios files
  Finished writing out configuraton
--------------------------------------

--------------------------------------
> Verifying configuration with Nagios Core
> Output:
Nagios Core 4.4.1
Copyright (c) 2009-present Nagios Core Development Team and Community Contributors
Copyright (c) 1999-2009 Ethan Galstad
Last Modified: 2018-06-25
License: GPL

Website: https://www.nagios.org
Reading configuration data...
   Read main config file okay...
   Read object config files okay...

Running pre-flight check on configuration data...

Checking objects...
   Checked 107 services.
   Checked 25 hosts.
   Checked 12 host groups.
   Checked 7 service groups.
   Checked 11 contacts.
   Checked 5 contact groups.
   Checked 141 commands.
   Checked 9 time periods.
   Checked 0 host escalations.
   Checked 0 service escalations.
Checking for circular paths...
   Checked 25 hosts
   Checked 110 service dependencies
   Checked 0 host dependencies
   Checked 9 timeperiods
Checking global event handlers...
Checking obsessive compulsive processor commands...
Checking misc settings...

Total Warnings: 0
Total Errors:   0

Things look okay - No serious problems were detected during the pre-flight check
> Return Code: 0
--------------------------------------
Stopping nagios: done.
Starting nagios: done.
OUTPUT=Starting nagios: done.
RETURNCODE=0
PROCESSING COMMAND ID 3677...
PROCESS COMMAND: CMD=1150, DATA=remove
CMDLINE=php /usr/local/nagiosxi/html/includes/components/nagiosbpi/api_tool.php --cmd=syncall
CMD: syncall
MSG: BPI configuration applied successfully! BPI configuration applied successfully!
OUTPUT=MSG: BPI configuration applied successfully! BPI configuration applied successfully!
RETURNCODE=0
belvdr
 
Posts: 81
Joined: Tue Oct 08, 2013 9:17 pm

Re: XI 5.5.0 / 5.5.1 - Unable to update components or config

Postby tmcdonald » Fri Jul 13, 2018 12:56 pm

Are you seeing any errors in /var/log/httpd/error_log when you try to update?

Please PM me a copy of your system profile. It is available under Admin -> System Config -> System Profile -> Download System Profile.

Update: Profile received and shared with team.
Former Nagios employee
tmcdonald
 
Posts: 9118
Joined: Mon Sep 23, 2013 8:40 am

Re: XI 5.5.0 / 5.5.1 - Unable to update components or config

Postby belvdr » Fri Jul 13, 2018 1:04 pm

tmcdonald wrote:Are you seeing any errors in /var/log/httpd/error_log when you try to update?

Please PM me a copy of your system profile. It is available under Admin -> System Config -> System Profile -> Download System Profile.

In /var/log/httpd/error_log:

None shown when attempting to update components.

When attempting to update the config wizards, I see

Code: Select all
[Fri Jul 13 14:02:37 2018] [error] [client <MY_CLIENT_IP>] PHP Notice:  Undefined variable: args in /usr/local/nagiosxi/html/admin/configwizards.php on line 620, referer: http://<NAGIOS_SERVER_FQDN>/nagiosxi/admin/configwizards.php?checkupdates=true


PM sent with the profile. I saw the following errors in /var/log/httpd/error_log when gathering the profile:
Code: Select all
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'
tar: Removing leading `/' from member names
belvdr
 
Posts: 81
Joined: Tue Oct 08, 2013 9:17 pm

Re: XI 5.5.0 / 5.5.1 - Unable to update components or config

Postby npolovenko » Fri Jul 13, 2018 4:19 pm

@belvdr, Are you able to connect to the database with the following command?
Code: Select all
mysql -uroot -pnagiosxi
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
npolovenko
Support Tech
 
Posts: 2013
Joined: Mon May 15, 2017 5:00 pm

Re: XI 5.5.0 / 5.5.1 - Unable to update components or config

Postby belvdr » Fri Jul 13, 2018 5:35 pm

npolovenko wrote:@belvdr, Are you able to connect to the database with the following command?
Code: Select all
mysql -uroot -pnagiosxi
Yes, no issues.
belvdr
 
Posts: 81
Joined: Tue Oct 08, 2013 9:17 pm

Re: XI 5.5.0 / 5.5.1 - Unable to update components or config

Postby belvdr » Fri Jul 13, 2018 6:30 pm

Tonight was patching night, so I did the usual yum update on the system.

After it rebooted, I figured I'd give it another shot. Lo and behold, it worked this time. I had tried rebooting before, wondering if something had a file locked or similar, but it didn't work then.

I cannot figure out why, but it solved itself.
belvdr
 
Posts: 81
Joined: Tue Oct 08, 2013 9:17 pm

Re: XI 5.5.0 / 5.5.1 - Unable to update components or config

Postby npolovenko » Mon Jul 16, 2018 2:52 pm

@belvdr, Hmm that is interesting. Maybe the browser needed to be restarted? Are we ok to lock this thread now?
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
npolovenko
Support Tech
 
Posts: 2013
Joined: Mon May 15, 2017 5:00 pm


Return to Nagios XI

Who is online

Users browsing this forum: Johnsmit, salami and 17 guests