Nagios reporting high memory usage but server doesn't.

This board serves as an open discussion and support collaboration point for Nagios XI. NOTE: Nagios XI customers should use the Customer Support forum to obtain expedited support.

Nagios reporting high memory usage but server doesn't.

Postby mjr2015 » Fri Jan 11, 2019 2:07 am

I'm monitoring my linux server by snmp and I'm receiving the following alert

Code: Select all
Physical memory: 89%used(28738MB/32163MB) (80%) : WARNING


however when I log into the server itself It says I am
Code: Select all
SERVER:~$ free -h
              total        used        free      shared  buff/cache   available
Mem:            31G         21G        3.3G        119M        6.6G        9.3G
Swap:          8.0G          0B        8.0G


any idea why it's alerting like this?
mjr2015
 
Posts: 5
Joined: Tue Dec 25, 2018 2:58 am

Re: Nagios reporting high memory usage but server doesn't.

Postby cdienger » Fri Jan 11, 2019 4:10 pm

Are you running the command on the XI side at the same time that the free command is being run on the monitored server? The check_snmp_storage_wizard.pl plugin pulls the OIDS holding the used and free values and divides one into the other to determine usage. Used can fluctuate and may differ from what the OID reports - try running "free -m" to get the output in megabytes reflect more of what the plugin sees.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
cdienger
Support Tech
 
Posts: 2318
Joined: Tue Feb 07, 2017 11:26 am

Re: Nagios reporting high memory usage but server doesn't.

Postby mjr2015 » Tue Jan 15, 2019 3:45 am

as close as possible:

Code: Select all
$free -m
free -m
              total        used        free      shared  buff/cache   available
Mem:          32163       21953        1709         106        8500        9647
Swap:          8191           1        8190

$date
Tue 15 Jan 08:43:40 GMT 2019



from nagios:
2019-01-15 08:42:35 Physical memory: 95%used(30476MB/32163MB) (>90%) : CRITICAL
mjr2015
 
Posts: 5
Joined: Tue Dec 25, 2018 2:58 am

Re: Nagios reporting high memory usage but server doesn't.

Postby scottwilkerson » Tue Jan 15, 2019 5:03 pm

Can you post the full command that nagios is running (from the CCM) for this check?
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
DevOps Engineer
 
Posts: 12916
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Re: Nagios reporting high memory usage but server doesn't.

Postby mjr2015 » Fri Jan 18, 2019 12:36 am

scottwilkerson wrote:Can you post the full command that nagios is running (from the CCM) for this check?



it's polling via SNMP

check_xi_service_snmp_linux_storage! --login=XXXX --passwd=XXXX --privpass=XXXXX --protocols=sha,aes -m Physical -w 80 -c 90 -f
mjr2015
 
Posts: 5
Joined: Tue Dec 25, 2018 2:58 am

Re: Nagios reporting high memory usage but server doesn't.

Postby scottwilkerson » Fri Jan 18, 2019 10:15 am

Looking at your results compared to the free comman you issues it looks correct.

The SNMP check takes all Physical memory into account including that which is being used for buff/cache
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
DevOps Engineer
 
Posts: 12916
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises


Return to Nagios XI

Who is online

Users browsing this forum: Google [Bot], hchohan1027 and 7 guests