Temporary name resoloution failed when creating a sensor

This board serves as an open discussion and support collaboration point for Nagios XI. NOTE: Nagios XI customers should use the Customer Support forum to obtain expedited support.

Temporary name resoloution failed when creating a sensor

Postby bkeating178 » Fri Jun 14, 2019 6:19 pm

I am trying to create sensors using the following variable in the command but I am getting the attached error every time regardless of the sensor or arguments that I use.

Any ideas what I could be doing wrong here?

This has worked on other sensors so it seems like the issue is the command/variable cannot resolve the hostname of the machine it is being attached to.
Attachments
8.JPG
bkeating178
 
Posts: 8
Joined: Thu May 09, 2019 11:40 am

Re: Temporary name resoloution failed when creating a sensor

Postby npolovenko » Mon Jun 17, 2019 12:09 pm

Hello, @bkeating178. Please save this configuration as it is, then go to the XI home page, find the service check and see whether it's working or showing the same error.
Could you also send in your Nagios XI System Profile so I can review it?
To send us your system profile. Login to the Nagios XI GUI using a web browser.
Click the "Admin" > "System Profile" Menu
Click the "Download Profile" button
Save the profile.zip file and send it to me in a private message.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
npolovenko
Support Tech
 
Posts: 3457
Joined: Mon May 15, 2017 5:00 pm

Re: Temporary name resoloution failed when creating a sensor

Postby npolovenko » Mon Jun 17, 2019 4:18 pm

@bkeating178, I don't think you can pass $HOSTADDRESS$ inside the $ARG1$ macro. It might work on the home page as I mentioned earlier. Please check.
If it doesn't work on the home page, you may need to use the actual IP instead of the $HOSTADDRESS$ or add this macro to the command itself:
Code: Select all
$USER1$/check_postgres.pl -H $HOSTADDRESS$ $ARG1$

And then delete -H $HOSTADDRESS$ from the $ARG1$ field in the service check settings.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
npolovenko
Support Tech
 
Posts: 3457
Joined: Mon May 15, 2017 5:00 pm


Return to Nagios XI

Who is online

Users browsing this forum: No registered users and 11 guests