Nagios XI Services NOT Monitored

This board serves as an open discussion and support collaboration point for Nagios XI. NOTE: Nagios XI customers should use the Customer Support forum to obtain expedited support.

Nagios XI Services NOT Monitored

Postby sgreen » Thu Jan 16, 2020 6:08 am

I have been using “Nagios XI” for a while now and this has worked very well until the other day. I have a Windows 2016 server configured as a Direct Access (DA) server. With two network cards one on my LAN & one in the DMZ

From the server (DA) I can ping my Nagios Server and the Nagios can both see & ping the the DA server, However, when it comes to Services I want to monitor on the (DA) server I get "CRITICAL - Socket timeout" This is from trying to monitor the C or D drives using this command line (password changed).

check_xi_service_nsclient!PASSWORD!USEDDISKSPACE!-l C -w 80 -c 95!!!!!

Nagios does not want to see these services at all, I have checked the firewall, and this is enabled with the NS Client configured to allow inbound access. The password within the local config file matches the correct one shown in the above command line. I have switched off the firewall on the Windows 2016 server to test and this made no difference.

I can PING the Nagios server from the DA server and the server shows as UP within Nagios. However, the services do not respond. I have removed and re-installed the client software and removed and add back the DA server using the Nagios "Windows server" wizard and this made no difference either.

Agent Version - NSCP 0.4.3.143-x64
Server Version - Nagios XI 5.6.9

Any ideas why the services can’t be seen?

Thanks - Steve
sgreen
 
Posts: 1
Joined: Thu Jan 16, 2020 5:52 am

Re: Nagios XI Services NOT Monitored

Postby benjaminsmith » Thu Jan 16, 2020 4:05 pm

Hi Steve,

Welcome to the Nagios Support Forum! Happy to have you here. Was this working correctly before? If so, any chance the IP address of the Windows server changed?

1. Verify the IP address for the allowed hosts filed in the nsclient,ini. Be sure to restart the service after making any changes.
Code: Select all
allowed hosts = <ipaddress Nagios XI server>

2. Run the following nmap command to see if the default NSClient port is available.
Code: Select all
nmap -p 12489 192.168.5.23

3. Try running the following command from the shell of the Nagios Server and let me know the results.
Code: Select all
/usr/local/nagios/libexec/check_nt -H IP_ADDRESS -s "YOUR_PASSWORD" -p 12489 -v UPTIME

4. If you still getting the same error, please upload the nsclient.ini file to the post. Thanks.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
benjaminsmith
 
Posts: 2059
Joined: Wed Aug 22, 2018 4:39 pm
Location: saint paul


Return to Nagios XI

Who is online

Users browsing this forum: No registered users and 24 guests