Nagios XI - Installing XI Fails To Install Dependency pymssql

Problem Description

When trying to install Nagios XI it fails with the following error:

--> Processing Dependency: pymssql for package: nagiosxi-deps-2012r2.9-1.noarch
--> Finished Dependency Resolution
Error: Package: nagiosxi-deps-2012r2.9-1.noarch (/nagiosxi-deps-2012r2.9-1.noarch)
           Requires: pymssql
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
RESULT=1

===================
INSTALLATION ERROR!
===================
Installation step failed - exiting.
Check for error messages in the install log (install.log).

If you require assistance in resolving the issue, please include install.log
in your communications with Nagios XI technical support.

The script that failed was: './1-prereqs'

 

Some of the original packages are not available through the standard repositories any more. To resolve the problem you need to add the Nagios Repository to the yum package manager.

 

 

Add Nagios Repository

There are different steps depending on your operating system, please refer to the following website for specific instructions:

Nagios Repositories

 

Once making these changes you will be able to re-run the fullinstall script to install Nagios XI.

 

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/

Posted by: - Mon, Oct 17, 2016 at 10:45 PM. This article has been viewed 3366 times.
Online URL: https://support.nagios.com/kb/article/nagios-xi-installing-xi-fails-to-install-dependency-pymssql-555.html

Powered by PHPKB (Knowledge Base Software)