Page 1 of 10

Using NRPE for windows server

PostPosted: Thu Dec 28, 2017 1:44 am
by skypete
hello i am new to nagios core was asking if someone could please help me and point me in the right direction.I am trying to use latest nrpe and ubuntu 16.04 could someone please explain on how to get nrpe function working to use with windows servers it is very complicated. i have tried many of the tutorials on nagios site and cannot seem to get it working. could someone please help me on this i have been stuck for quite some time.

Re: Using NRPE for windows server

PostPosted: Thu Dec 28, 2017 10:57 am
by bolson
Have you installed NSClient++ on the Windows host? Any installation issues? Can you run the following command from you ubuntu host and post the result:

Code: Select all
telnet <ip_addr_of_windows_host> 5666

Re: Using NRPE for windows server

PostPosted: Fri Dec 29, 2017 2:07 pm
by skypete
Hi thank you for the reply i have installed it on win 2012 server. Let me try that command and thank you for you help.

Re: Using NRPE for windows server

PostPosted: Fri Dec 29, 2017 2:13 pm
by npolovenko
@skypete, We need some more information to be able to help you. Can you describe the steps you took to install NRPE and what issues you've encountered?

Re: Using NRPE for windows server

PostPosted: Fri Dec 29, 2017 2:17 pm
by dwhitfield
So, I think you already answered @npolovenko's question. You installed NSClient, which installed NRPE. Is that correct?

If so, please attach your NSC.ini or NSClient.ini.

What version of NSClient are you using? What error messages, if any are you getting? Also, the output of the command @bolson asked for yesterday would still be useful.

Re: Using NRPE for windows server

PostPosted: Fri Dec 29, 2017 3:34 pm
by skypete
still not working is there a step by step guide on how to setup and install on NRPE on nagios core for window servers?

Re: Using NRPE for windows server

PostPosted: Fri Dec 29, 2017 3:43 pm
by dwhitfield
Please attach your NSC.ini or NSClient.ini.

Most of our documentation is written for XI, but it should help you get your NSClient.ini set up properly: https://assets.nagios.com/downloads/nag ... ios-XI.pdf

Re: Using NRPE for windows server

PostPosted: Fri Dec 29, 2017 4:45 pm
by skypete
Standby i will get you that info and thank you.

Re: Using NRPE for windows server

PostPosted: Fri Dec 29, 2017 5:52 pm
by tmcdonald
Sounds good. Please note, we will have modified office hours next week for New Year's.

Re: Using NRPE for windows server

PostPosted: Fri Dec 29, 2017 5:52 pm
by skypete
Here is my Ini file as requested and the screenshot of the command you asked me to run. Also forgot to mentioned i did not add the window host to a cfg file for hosts and services that is what I am stuck with now. Also the version I am using version NSCP-0.5.1.44-x64