Problems installing Nagios-3.2.3 on ubuntu 10.10

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Problems installing Nagios-3.2.3 on ubuntu 10.10

Postby tsioutas » Thu Jul 07, 2011 8:58 am

Hi there.

I ve installed nagios-3.2.3
I ve installed apache2

I ve checked the status of both

/etc/init.d/nagios status
up and running

/etc/init.d/apache2 status
up and running

But cannot reach the web interface

Any ideas??? please help
tsioutas
 
Posts: 3
Joined: Thu Jul 07, 2011 8:52 am

Re: Problems installing Nagios-3.2.3 on ubuntu 10.10

Postby lmiltchev » Thu Jul 07, 2011 9:09 am

Disable your firewall (iptables) temporarily to eliminate this possibility and also check your selinux. You can disable it temporarily by running in terminal: "setenforce 0"
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
lmiltchev
QA Manager
 
Posts: 12630
Joined: Mon May 23, 2011 12:15 pm

Re: Problems installing Nagios-3.2.3 on ubuntu 10.10

Postby tsioutas » Thu Jul 07, 2011 9:28 am

I just did it but nothing. Any other ideas?
tsioutas
 
Posts: 3
Joined: Thu Jul 07, 2011 8:52 am

Re: Problems installing Nagios-3.2.3 on ubuntu 10.10

Postby mguthrie » Thu Jul 07, 2011 12:40 pm

Did you install from source of using apt? If you're using apt you need to access the page from http://<address>/nagios3. Take a look at your /etc/apache2/conf.d directory and see where the nagios alias is pointing. Verify that it's pointing to the correct directory location for the web front-end.
mguthrie
 
Posts: 4384
Joined: Mon Jun 14, 2010 10:21 am

Re: Problems installing Nagios-3.2.3 on ubuntu 10.10

Postby tsioutas » Fri Jul 08, 2011 2:34 am

/etc/apache2conf.d contains the following files :

charset localised-error-pages other-vhosts-access-log security

which one should I configure?
tsioutas
 
Posts: 3
Joined: Thu Jul 07, 2011 8:52 am

Re: Problems installing Nagios-3.2.3 on ubuntu 10.10

Postby mguthrie » Fri Jul 08, 2011 9:24 am

If you installed from apt you should already have a file somewhere called nagios3.conf. Otherwise if you installed from source, one of the last steps in the install process is "make install-webconf" and that will create the apache conf file for you as well. If you don't have either of these, here's the conf file from a source install. Change file and directory locations to match your install. You'll need to use the htpasswd command to add a password protected user to the htpasswd.users file.

Code: Select all
ScriptAlias /nagios/cgi-bin "/usr/local/nagios/sbin"

<Directory "/usr/local/nagios/sbin">
#  SSLRequireSSL
   Options ExecCGI
   AllowOverride None
   Order allow,deny
   Allow from all
#  Order deny,allow
#  Deny from all
#  Allow from 127.0.0.1
   AuthName "Nagios Core"
   AuthType Basic
   AuthUserFile /usr/local/nagiosxi/etc/htpasswd.users
   Require valid-user
</Directory>

Alias /nagios "/usr/local/nagios/share"

<Directory "/usr/local/nagios/share">
#  SSLRequireSSL
   Options None
   AllowOverride None
   Order allow,deny
   Allow from all
#  Order deny,allow
#  Deny from all
#  Allow from 127.0.0.1
   AuthName "Nagios Core"
   AuthType Basic
   AuthUserFile /usr/local/nagiosxi/etc/htpasswd.users
   Require valid-user
</Directory>
mguthrie
 
Posts: 4384
Joined: Mon Jun 14, 2010 10:21 am


Return to Nagios Core

Who is online

Users browsing this forum: No registered users and 13 guests