Nagios core CLI is working but Nagios web console is not.

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Re: Nagios core CLI is working but Nagios web console is not

Postby ssax » Mon Jan 07, 2019 4:59 pm

Code: Select all
lendingkart@LK-LP-565:~$ curl -L nagios.lendingkart.com -vvv
* Rebuilt URL to: nagios.lendingkart.com/
*   Trying 172.31.32.238...
* Connected to nagios.lendingkart.com (172.31.32.238) port 80 (#0)
> GET / HTTP/1.1
> Host: nagios.lendingkart.com
> User-Agent: curl/7.47.0
> Accept: */*
>
< HTTP/1.1 502 Connection refused
< Date: Fri, 04 Jan 2019 07:56:43 GMT
< Cache-Control: no-cache
< Pragma: no-cache
< Content-Type: text/html; charset="UTF-8"
< Content-Length: 71993
< Via: HTTP/1.1 forward.http.proxy:3128


Your proxy is refusing for some reason, please validate with your Proxy Admins:

< HTTP/1.1 502 Connection refused
< Date: Fri, 04 Jan 2019 07:56:43 GMT
< Via: HTTP/1.1 forward.http.proxy:3128

That's why the internal one that you ran when it was not working actually worked.

So for some reason your proxy is not allowing it *SOMETIMES*, your proxy admins will need to check the logs.

We can see it from the output:

Code: Select all
generateText('connection_fail');

connection_fail: [
                                            NOT_AVAIL, SITE_NOT_AVAIL,
                                            'The website you requested cannot be accessed. It may work if you try again later.',
                                            "We found the website's address but were unable to connect to the web server."
                                        ],
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
ssax
Dreams In Code
 
Posts: 3911
Joined: Wed Feb 11, 2015 12:54 pm

Re: Nagios core CLI is working but Nagios web console is not

Postby satya » Thu Jan 10, 2019 4:51 am

Hi ssax,

Thanks for pointing it out. Let me have a word with the internal team and will let you know :)

Regards,
Satya
satya
 
Posts: 8
Joined: Mon Oct 08, 2018 7:39 am

Re: Nagios core CLI is working but Nagios web console is not

Postby satya » Thu Jan 10, 2019 6:55 am

Hi ssax,

I had a word with the team, there is no such proxy set. We tried disabling our external firewall but still the issue exists.

Regards,
Satya
satya
 
Posts: 8
Joined: Mon Oct 08, 2018 7:39 am

Re: Nagios core CLI is working but Nagios web console is not

Postby scottwilkerson » Thu Jan 10, 2019 12:46 pm

satya wrote:Hi ssax,

I had a word with the team, there is no such proxy set. We tried disabling our external firewall but still the issue exists.

Regards,
Satya


What did they say about this?
Code: Select all
Via: HTTP/1.1 forward.http.proxy:3128
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
DevOps Engineer
 
Posts: 14054
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Previous

Return to Nagios Core

Who is online

Users browsing this forum: No registered users and 15 guests