xinetd[6199]: FAIL: nrpe per_source_limit from=ip_nagios

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

xinetd[6199]: FAIL: nrpe per_source_limit from=ip_nagios

Postby arey » Fri May 06, 2011 9:33 am

I´m having a message error shown at my server log:
xinetd[6199]: FAIL: nrpe per_source_limit from=ip_nagios_server.

This message it´s shown at the log while my contacts receive multiple times at the day this message:
CHECK_NRPE: Error - Could not complete SSL handshake.

The NRPE version installed is v2.12
The product it's Nagios Core 3.2.1

I had reviewed the file from the monitored server: /etc/xinetd.d/nrpe.cfg because of the message also display in the server log:

the nrpe[14368]: Unable to open config file '/etc/xinetd.d/nrpe.cfg' from reading.
but i have the following (i didn´t modify this file): -rw-r--r-- 1 root root 475 May 26 2010 nrpe

# default: on
# description: NRPE (Nagios Remote Plugin Executor)
service nrpe
{
flags = REUSE
socket_type = stream
port = 5666
wait = no
user = nagios
group = nagios
server = /usr/local/nagios/bin/nrpe
server_args = -c /usr/local/nagios/etc/nrpe.cfg --inetd
log_on_failure += USERID
disable = no
only_from = 127.0.0.1 ip_nagios_server
}

Should i rebuild nrpe with ssl?? i can´t restart xinetd, i have all my services working.
As far as has had checked the others server that are monitored by Nagios uses the same configuration, but not showing this problem.
arey
 
Posts: 1
Joined: Thu May 05, 2011 7:11 pm

Re: xinetd[6199]: FAIL: nrpe per_source_limit from=ip_nagios

Postby mguthrie » Fri May 06, 2011 4:51 pm

You may not need to rebuild nrpe, but you may want to make sure you have openssl and openssl-devel packages installed on your system.
mguthrie
 
Posts: 4380
Joined: Mon Jun 14, 2010 10:21 am

Re: xinetd[6199]: FAIL: nrpe per_source_limit from=ip_nagios

Postby anbusiness » Thu May 12, 2011 11:17 am

I had found the answer to that. It was two things:
Some of my services were flapping, i just realized that while i was monitoring other server, i found on the web monitor the message: service started flapping.
I checked out some documentation and i found that flapping makes nrpe plugin to fail.
This persistency was started by having problems responding from that server to the monitor server.
I double checked the conections availables in the server and i found and unhappy surprise:

ps -ef | grep nrpe

Stikky conections, i read the configuration for Xinedt service and found that the max allow conections where 10 and i had more that 15 in the server whom error i was reporting first. i checked it out in other servers (one with the message started flapping and other 2 with no problem at all).

kill -9 (pid's)

Killing all the extra conections the web monitor started showing RECOVERY for all my services :)
I felt relief!!!


SOLVED!
anbusiness
 
Posts: 2
Joined: Sun Apr 03, 2011 10:33 pm


Return to Community Support

Who is online

Users browsing this forum: M.Morsy and 10 guests