error general time-out (alarm signal)

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

error general time-out (alarm signal)

Postby shamrozkadiwal » Tue Jan 08, 2019 10:49 am

I have been getting this "error general time-out (alarm signal)" with few servers. This is just one server example. I tried to google to find the solution but nothing work.
Attachments
Service.txt
Service
(1.28 KiB) Downloaded 98 times
host.txt
Host
(1.79 KiB) Downloaded 98 times
asftp900.JPG
shamrozkadiwal
 
Posts: 74
Joined: Thu Jan 25, 2018 1:13 am

Re: error general time-out (alarm signal)

Postby shamrozkadiwal » Tue Jan 08, 2019 10:50 am

I have also uploaded check_command config
Attachments
test.txt
(4.17 KiB) Downloaded 87 times
command.txt
check_command
(919 Bytes) Downloaded 100 times
shamrozkadiwal
 
Posts: 74
Joined: Thu Jan 25, 2018 1:13 am

Re: error general time-out (alarm signal)

Postby ssax » Tue Jan 08, 2019 5:16 pm

Please change your commands to these:

Code: Select all
define command{
        command_name check_snmp_storage_ux_root
        command_line $USER1$/check_snmp_storage.pl -H $HOSTADDRESS$ -t 90 -C $ARG1$ -m / -r -q FixedDisk -w90 -c95 -G
        }

define command{
        command_name check_snmp_storage_ux_not_root
        command_line $USER1$/check_snmp_storage.pl -H $HOSTADDRESS$ -t 90 -C $ARG1$ -m / -r -e -q FixedDisk -w90 -c95 -G
        }


Then edit your /usr/local/nagios/etc/nagios.cfg and adjust your service_check_timeout to match:

Code: Select all
service_check_timeout=90


Then restart the nagios service:

Code: Select all
service nagios restart


Let us know if that resolves the issue.

Thank you
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
ssax
Dreams In Code
 
Posts: 4232
Joined: Wed Feb 11, 2015 12:54 pm

Re: error general time-out (alarm signal)

Postby cdienger » Tue Jan 08, 2019 5:17 pm

The commands that are failing are using snmp. Is the host configured to use snmp? Check to see if it is up and responding with:

nmap 10.180.50.100 -p 161 -sU
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
cdienger
Support Tech
 
Posts: 3511
Joined: Tue Feb 07, 2017 11:26 am

Re: error general time-out (alarm signal)

Postby tgriep » Tue Jan 08, 2019 5:21 pm

First thing to do is to verify that the Host has SNMP enabled in it and that the community string you are using in the commands are valid.
If the remote host is not setup for SNMP polling, it will cause the timeout.
Another thing, make sure the firewall allows inbound UDP connections on port 161. That is required.

And, you may need to specify the SNMP version for the check_snmp plugin's command line option.
Code: Select all
-P, --protocol=[1|2c|3]
    SNMP protocol version
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
tgriep
Madmin
 
Posts: 8204
Joined: Thu Oct 30, 2014 9:02 am

Re: error general time-out (alarm signal)

Postby shamrozkadiwal » Wed Jan 09, 2019 10:36 am

cdienger wrote:The commands that are failing are using snmp. Is the host configured to use snmp? Check to see if it is up and responding with:

nmap 10.180.50.100 -p 161 -sU


It seems good to me.
Code: Select all
[root@ams900 ~]# nmap 10.180.50.100 -p 161 -sU

Starting Nmap 7.01 ( https://nmap.org ) at 2019-01-09 09:22 CST
Nmap scan report for asftp900.enclave.local (10.180.50.100)
Host is up (0.00029s latency).
PORT    STATE  SERVICE
161/udp closed snmp

Nmap done: 1 IP address (1 host up) scanned in 0.15 seconds
[root@ams900 ~]#
shamrozkadiwal
 
Posts: 74
Joined: Thu Jan 25, 2018 1:13 am

Re: error general time-out (alarm signal)

Postby shamrozkadiwal » Wed Jan 09, 2019 10:52 am

ssax wrote:Please change your commands to these:

Code: Select all
define command{
        command_name check_snmp_storage_ux_root
        command_line $USER1$/check_snmp_storage.pl -H $HOSTADDRESS$ -t 90 -C $ARG1$ -m / -r -q FixedDisk -w90 -c95 -G
        }

define command{
        command_name check_snmp_storage_ux_not_root
        command_line $USER1$/check_snmp_storage.pl -H $HOSTADDRESS$ -t 90 -C $ARG1$ -m / -r -e -q FixedDisk -w90 -c95 -G
        }


Then edit your /usr/local/nagios/etc/nagios.cfg and adjust your service_check_timeout to match:

Code: Select all
service_check_timeout=90


Then restart the nagios service:

Code: Select all
service nagios restart


Let us know if that resolves the issue.

Thank you


I made the changes whatever you recommended but it didn't work out. It threw error "Invalid timeout value...." you can see in the picture
Attachments
Capture.JPG
shamrozkadiwal
 
Posts: 74
Joined: Thu Jan 25, 2018 1:13 am

Re: error general time-out (alarm signal)

Postby tgriep » Wed Jan 09, 2019 1:47 pm

The nmap command shows that the UDP port 161 is closed so that is not good.
Check that server and verify that it is running SNMP.

The timeout error for the plugin is caused by a too large of value for the -t option, set it to 60 seconds and that will fix that.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
tgriep
Madmin
 
Posts: 8204
Joined: Thu Oct 30, 2014 9:02 am

Re: error general time-out (alarm signal)

Postby shamrozkadiwal » Wed Jan 09, 2019 1:57 pm

tgriep wrote:First thing to do is to verify that the Host has SNMP enabled in it and that the community string you are using in the commands are valid.
If the remote host is not setup for SNMP polling, it will cause the timeout.
Another thing, make sure the firewall allows inbound UDP connections on port 161. That is required.

And, you may need to specify the SNMP version for the check_snmp plugin's command line option.
Code: Select all
-P, --protocol=[1|2c|3]
    SNMP protocol version


tgriep, I checked on the server and snmpd wasn't installed so I installed it. Snmpd service is running.
Attachments
snmp.txt
(4.03 KiB) Downloaded 103 times
shamrozkadiwal
 
Posts: 74
Joined: Thu Jan 25, 2018 1:13 am

Re: error general time-out (alarm signal)

Postby tgriep » Wed Jan 09, 2019 2:05 pm

Thanks for the update. All that is left to do is to fix the -t value to 60 on the command and to test it out.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
tgriep
Madmin
 
Posts: 8204
Joined: Thu Oct 30, 2014 9:02 am

Next

Return to Nagios Core

Who is online

Users browsing this forum: gathomso and 38 guests