Nagflux not sending all Data

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

Nagflux not sending all Data

Postby Pradeeps » Wed Jun 10, 2020 1:10 pm

Hello Folks,

I am running Nagios core - 4.2.4 on a centos 7 machine. I have installed and configured naglux which feeds performance data to the influxDB in grafana. I am seeing an issue that not all services are being sent to influxDB. Looking at the error log (/nagflux.dump-nagflux.influx-errors) , I see this ,

One of the values is not clean..
metrics,host=a\ -\ b\ [c]\ -\ d\ e\ [f-g]\ -\ h\ [i-j]\ -\ ip,service=HP-UPS-Check_Load_current,command=HP-UPS-Check_load_current,performanceLabel=iso.3.6.1.4.1.7309.5.3.1.11.0,warn-fill=none value=50.0,warn=4000.0 1591812201000


Perhaps Nagflux expect any specific format to send data to influxdb?
Pradeeps
 
Posts: 38
Joined: Thu Dec 22, 2016 11:05 am

Re: Nagflux not sending all Data

Postby Pradeeps » Fri Jun 12, 2020 11:23 am

Anyone could comment on this?
Pradeeps
 
Posts: 38
Joined: Thu Dec 22, 2016 11:05 am

Re: Nagflux not sending all Data

Postby cdienger » Wed Jun 17, 2020 4:39 pm

Nagflux is not a project that we maintain so you may have better luck finding help if you reach out to their support.

That said, we do have this document which you may want to review to confirm settings: https://support.nagios.com/kb/article/n ... u-802.html
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
cdienger
Support Tech
 
Posts: 4594
Joined: Tue Feb 07, 2017 11:26 am


Return to Community Support

Who is online

Users browsing this forum: Majestic-12 [Bot] and 26 guests