THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Products » Nagios Core » Troubleshooting » Common Problems

Nagios Core - ERROR: Could not create or update nagios.configtest

Problem Description

This KB article applies to the following error message when starting Nagios Core:

ERROR: Could not create or update '/usr/local/nagios/var/nagios.configtest'

 

 

Explanation

This problem occurs when the nagios user account does not have a user shell, typically when nologin is used in the passwd file:

nagios:x:1001:1001::/home/nagios:/usr/sbin/nologin

 

 

Resolution

The resolution to this problem is to remove the /usr/sbin/nologin directive from the passwd file, or to define it as a valid shell. The following examples should resolve the problem (depending on your operating system):

No shell defined:

nagios:x:1001:1001::/home/nagios:

 

Bash shell defined:

nagios:x:500:500::/home/nagios:/bin/bash

 

Once you have updated the passwd file you will be able to successfully start the nagios service.

 

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

1 (2)
Article Rating (2 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Nagios Core - Nagios service does not start - Error processing object config files!
Viewed 35577 times since Thu, Jan 21, 2016
How To Clear Solaris Service Maintenance Status
Viewed 38046 times since Mon, Mar 6, 2017
Nagios Core - How to Think with Nagios to Solve Monitoring Problems - NWC14
Viewed 9546 times since Mon, Feb 8, 2016
Nagios XI - Uploaded plugin returns "/bin/bash^M: bad interpreter: No such file or directory"
Viewed 10553 times since Thu, Feb 25, 2016
Pages Not Displaying Correctly
Viewed 10897 times since Mon, Jan 25, 2016
Nagios XI - MK Livestatus Problems With Mod-Gearman
Viewed 7984 times since Thu, Feb 25, 2016
Nagios Core - Failed to register iobroker
Viewed 9302 times since Wed, Sep 20, 2017
Nagios Core - Nagios did not exit in a timely manner
Viewed 11698 times since Wed, Jan 27, 2016
SNMP Trap - How To Send A Test Trap
Viewed 248444 times since Fri, Apr 1, 2016
Nagios Core - nagios.lock Changes In 4.3.3 Onwards
Viewed 15221 times since Tue, Jan 30, 2018