THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Multiple Categories

Nagios Core - Nagios did not exit in a timely manner

Problem Description

In larger deployments of nagios, stopping or restarting the nagios service may result in the error:

Nagios did not exit in a timely manner

This is due to many factors in large deployments, but basically it is just a timeout issue.

 

Resolving The Problem

You can update the nagios init script to increase how long the script is allowed to run for.

Edit the file of /etc/init.d/nagios and find this line:

for i in 1 2 3 4 5 6 7 8 9 10 ; do

 Change it to:

for i in {1..90} ; do

 

This changes the timeout to 90 seconds, increase to a larger number as required.

 
NOTE

This change will be overwritten each time an upgrade of Nagios XI or Nagios Core occurs, you will need to re-modify after an upgrade.

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

1.44 (9)
Article Rating (9 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Nagios XI - Installing Latest SourceGuardian Loaders
Viewed 10718 times since Mon, Jun 18, 2018
Nagios XI - ICMP and Ping Checks Stopped Graphing
Viewed 17247 times since Mon, Jan 25, 2016
SSL Certificate does not validate properly
Viewed 7771 times since Wed, Jan 20, 2021
Nagios XI - SQL Error [nagiosxi] : ERROR: syntax error
Viewed 10634 times since Sun, Sep 10, 2017
Nagios XI - Migrate Performance Data
Viewed 16123 times since Tue, Jan 26, 2016
Nagios XI - Installing XI Fails To Install Dependency pymssql
Viewed 11009 times since Mon, Oct 17, 2016
Upgrading to NDO 3 after having been downgraded in newer versions of Nagios XI
Viewed 6258 times since Fri, Jan 15, 2021
Nagios XI - Troubleshooting Reports
Viewed 9983 times since Wed, Dec 5, 2018
Active Directory / LDAP - Troubleshooting Authentication Integration
Viewed 23943 times since Mon, Jun 26, 2017
Nagios XI - Uploaded plugin returns "/bin/bash^M: bad interpreter: No such file or directory"
Viewed 10552 times since Thu, Feb 25, 2016