THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Multiple Categories

Web Browser Reports 330 Error Content Encoding

Problem Description

In rare circumstances you may come across the following error in your web browser when accessing one of the Nagios products:

Content Encoding Error

The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

* Please contact the website owners to inform them of this problem.

Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.

 

 

Resolution

The Apache web server requires zlib.output_compression to be configured to On in the /etc/php.ini file.

Execute the following command to open the file in vi:

vi /etc/php.ini

When using the vi editor, to make changes press i on the keyboard first to enter insert mode. Press Esc to exit insert mode.

 

To locate the line zlib.output_compression = type the following:

/output_compression =

 

This should take you directly to the line. Change the setting to On:

zlib.output_compression = On

 

When you have finished, save the changes in vi by typing:

:wq

and press Enter.

 

The last step is to restart the Apache service using one of the commands below:

 

RHEL 7 + | CentOS 7 + | Oracle Linux 7 +

systemctl restart httpd.service

 

Debian | Ubuntu 16/18/20

systemctl restart apache2.service

 

 

After the service has restarted the problem should no longer occur.

 

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

1 (2)
Article Rating (2 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Nagios Core - Nagios service does not start - Error processing object config files!
Viewed 35576 times since Thu, Jan 21, 2016
Nagios Log Server - Troubleshooting Backups
Viewed 7898 times since Fri, Apr 15, 2016
Nagios XI - Best Practices - NWC15
Viewed 10816 times since Thu, Feb 4, 2016
Nagios XI - Notifications Not Sending In XI 5.3.0
Viewed 7509 times since Tue, Oct 4, 2016
Nagios XI - Apply Configuration Never Completes
Viewed 26094 times since Tue, Jan 27, 2015
Nagios Fusion - Resetting The nagiosadmin Password
Viewed 6183 times since Tue, May 23, 2017
OpenSSL causes issue with check_nrpe plugin with NSClient++
Viewed 14923 times since Fri, Apr 30, 2021
Nagios XI - How To Use CA Certificates With check_ldaps Plugin
Viewed 16465 times since Tue, Jul 26, 2016
Nagios Log Server - License Activation Issues
Viewed 6441 times since Wed, Dec 13, 2017
Upgrading to NDO 3 after having been downgraded in newer versions of Nagios XI
Viewed 6258 times since Fri, Jan 15, 2021