THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Multiple Categories

Nagios XI - Profile Build Failed

Problem Description

When you go to Admin > System Config > System Profile and try to download the profile you receive the following error:

PROFILE BUILD FAILED

Array
(
)

CODE: 1

 
 

Resolving The Problem

This problem is occurring because the required sudoers entries are missing.

The following steps shows you how to get the correct sudoers entries from the XI installation file. It is not possible to provide all the entries in this KB article as they may change in newer versions of XI. These steps ensure you get the correct entries for your version of Nagios XI.

First you must download the XI installation file to your Nagios XI server. You'll do this with the WGET command. Please refer to the following link to get the correct download link for your version of Nagios XI:

Download Page - Nagios XI Versions

Open an ssh session to your Nagios XI host.

Execute the following commands (use your XI version download link in the wget command):

cd /tmp
wget https://assets.nagios.com/downloads/nagiosxi/5/xi-5.6.3.tar.gz

 

Once downloaded you'll need to use the name of the downloaded file in the next command, in this example xi-5.6.3.tar.gz is the name being used:

tar xzf xi-5.6.3.tar.gz nagiosxi/nagiosxi/nagiosxi.sudoers --strip-components 2


This will have extracted a file called nagiosxi.sudoers and this file contains all the correct entries.

Run all these commands to fix your /etc/sudoers file to make sure it has all the correct entries:

grep -v NAGIOSXI /etc/sudoers > /etc/sudoers.new
mv -f /etc/sudoers.new /etc/sudoers
rm -rf /etc/sudoers.d/nagiosxi
sed -i 's/^Defaults    requiretty/#Defaults    requiretty/g' /etc/sudoers
cat /tmp/nagiosxi.sudoers >> /etc/sudoers
chmod 440 /etc/sudoers


After making these changes try and download the system profile, your problem should be resolved.

 

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

1 (3)
Article Rating (3 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Managing Service Templates
Viewed 11949 times since Mon, Jun 28, 2021
Nagios Core - Failed to register iobroker
Viewed 9280 times since Wed, Sep 20, 2017
Nagios XI - How to Change Default Passwords
Viewed 12351 times since Wed, Jan 27, 2016
Nagios XI - Utilizing a RAM Disk in Nagios XI
Viewed 11140 times since Thu, Jan 28, 2016
Nagios XI - Status Information Cut Off At 256 Characters
Viewed 10379 times since Thu, Feb 25, 2016
Nagios XI - Plain Text Password Considerations
Viewed 15202 times since Mon, Jun 18, 2018
Nagios XI - Last Check Time Not Updating
Viewed 27676 times since Tue, Jan 6, 2015
Nagios XI - Integrating autoIT With Nagios
Viewed 7500 times since Wed, Jan 27, 2016
Nagios XI - Hardware Requirements - Baseline Testing
Viewed 8971 times since Sun, Jul 17, 2016
XI 5.10.0 and newer Postgress to MySQL Conversion
Viewed 34423 times since Tue, Dec 6, 2016