Home » Categories » Multiple Categories

Enabling Oracle Linux Optional Repository

Problem Description

When you attempt to install or upgrade one of the Nagios products you receive the following error:

ERROR: Please enable the 'Optional' repo for your system in:

 

Resolving The Problem

You need to add the Optional repository so that Nagios XI can install the necessary prerequisites using the commands below:

yum install -y yum-utils
yum-config-manager --enable ol7_optional_latest

 

That's it! You should be able to run the installer again and complete your installation.

 

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/

0 (0)
Article Rating (No Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Nagios XI - Troubleshooting Reports
Viewed 392 times since Wed, Dec 5, 2018
Nagios XI - Apply Configuration Never Completes
Viewed 1456 times since Tue, Jan 27, 2015
NDOUtils - Message Queue Exceeded
Viewed 1505 times since Thu, Jan 21, 2016
Nagios XI - MySQL/MariaDB - Max Connections
Viewed 1653 times since Thu, Jun 2, 2016
Nagios XI - Resolving "Cannot connect to database" Error - Core Config Manager
Viewed 548 times since Mon, Jan 25, 2016
Nagios XI - Importing Nagios XI into Microsoft Hyper-V
Viewed 334 times since Thu, Jan 28, 2016
Nagios XI - Ajaxterm Installation Aborted
Viewed 319 times since Tue, Jan 26, 2016
Nagios XI - Configuration Applies, No Changes Take Place
Viewed 558 times since Tue, Jan 27, 2015
Nagios XI - Problems with $ Signs in the Check Command
Viewed 602 times since Tue, Jan 26, 2016
Nagios XI - ERROR: PostgresQL not running - exiting
Viewed 383 times since Tue, Jan 26, 2016