THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Products » Nagios XI » Troubleshooting » Common Problems

Nagios XI - CentOS 6 Installation Problems XI 2011R1.7 2011R1.8

Problem Description

Between the the release of Nagios XI 2011R1.7 and 1.8, several changes were made to the CentOS 6 repo that created package conflicts, preventing the Nagios XI installation scripts from completing successfully. This usually becomes apparent by the "fullinstall" script failing with one of the following two messages:

ERROR: Prerequisite program 'mysql' not found!
which: no mysqladmin in (/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:   /usr/sbin:/sbin:/home/admin/bin)
ERROR: Prerequisite program 'mysqladmin' not found!
7 prerequisite(s) missing - exiting.

 OR

ls: cannot access /usr/local/nagiosxi/nom/checkpoints/nagioscore/*.gz: No such file or directory
NO NOM SNAPSHOT FOUND!
ERROR: NagiosQL import appears to have failed - exiting.  (Reason: Import files are still present in /usr/local/nagios/etc/import)

 

Resolving The Problem

This issue can be resolved with the following solution if you're attempting to install with the 1.7 tarball. This problem will be resolved in the 2011R1.8 release of Nagios XI.

Before attempting any more installations, run:

yum install centos-release-cr

 

Then remove any previous /tmp/nagiosxi directory that is in place, and unpack a fresh tarball:

cd /tmp
rm -rf nagiosxi
tar zxf xi-2011r1.7.tar.gz
cd nagiosxi
./fullinstall

 

 If the installer still fails, contact XI support and attach the install.log file that's generated by the fullinstall script.

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

1 (1)
Article Rating (1 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Web Browser Reports 330 Error Content Encoding
Viewed 10543 times since Tue, Mar 7, 2017
Nagios XI - Profile Build Failed
Viewed 16402 times since Tue, Aug 2, 2016
Nagios XI - Resetting The nagiosadmin Password
Viewed 53493 times since Mon, Jan 25, 2016
Nagios XI - Status Information Cut Off At 256 Characters
Viewed 10409 times since Thu, Feb 25, 2016
Nagios XI - ERROR: unable to open include file: conf.d/*.cfg
Viewed 11417 times since Sun, May 29, 2016
Nagios XI - mysql_error out of range value for column
Viewed 9746 times since Tue, Aug 14, 2018
Nagios XI - Downloading A System Profile
Viewed 10739 times since Wed, Jul 19, 2017
Nagios XI - Scheduled Reports Not Running
Viewed 7765 times since Thu, Aug 10, 2017
Nagios XI - 2014 Upgrade Issue - CONFIG ERROR
Viewed 7930 times since Mon, Jan 25, 2016
Nagios XI - How To Delete A Data Source From An RRD File
Viewed 16831 times since Wed, Apr 27, 2016