THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Multiple Categories

Nagios XI - Oracle Services Critical After Nagios XI Upgrade

Problem Description

After upgrading Nagios XI, Oracle based services start failing with errors similar to this:

The following error message is produced:

CRITICAL - cannot connect to fprnt. install_driver(Oracle) failed: Can't load '/usr/local/lib64/perl5/auto/DBD/Oracle/Oracle.so' for module DBD::Oracle: libocci.so.12.1: cannot open shared object file: No such file or directory at /usr/lib64/perl5/DynaLoa    

 

Explanation

During the upgrade, the customized commands are overwritten with the default commands included with the wizard.

 

Resolving The Problem

The old commands can be retrieved as they would have been kept in a backup.

If you did the upgrade via the XI web interface, the following file is created:

/store/backups/nagiosxi/autoupgrade_backup..tar.gz

Follow these steps in an SSH or console session on your Nagios XI host:

mkdir /tmp/restore/
cd /tmp/restore/
tar zxf /store/backups/nagiosxi/autoupgrade_backup..tar.gz -C /tmp/restore/
tar zxf /tmp/restore/autoupgrade_backup./nagios.tar.gz usr/local/nagios/etc/commands.cfg --strip-components 4

 
This last step will show you what the commands were defined as before the upgrade:

grep oracle /tmp/restore/commands.cfg


Using that information you will be able to go into CCM and update the commands accordingly following this original guide on page 2 and 3:

Documentation - How to Install & Configure the Oracle Client & Plugins

 

When you are done, delete the extracted files:

cd /tmp
rm -rf restore


 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

2.33 (3)
Article Rating (3 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Nagios XI - Notification Problems
Viewed 35484 times since Tue, Jan 27, 2015
Nagios XI - Ajaxterm Installation Aborted
Viewed 6030 times since Tue, Jan 26, 2016
Nagios XI - Installing The Solaris Agent
Viewed 9248 times since Wed, Jan 27, 2016
Nagios XI - Best Practices - NWC15
Viewed 10816 times since Thu, Feb 4, 2016
Nagios XI - Installing the XI Mac OS/X Agent
Viewed 8715 times since Wed, Jan 27, 2016
Nagios XI - Login Screen Keeps Redirecting To Itself
Viewed 9229 times since Wed, Jan 27, 2016
Nagios XI - Monitoring Linux Using SNMP
Viewed 16227 times since Thu, Jan 28, 2016
Nagios XI - Installing The Linux Agent
Viewed 18439 times since Wed, Jan 27, 2016
Nagios XI - Using Auto-Discovery
Viewed 12945 times since Thu, Aug 17, 2017
Nagios XI - Host Still Visible After Deletion (Ghost Hosts)
Viewed 14848 times since Tue, Jan 27, 2015