THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Products » Nagios XI » Troubleshooting » Common Problems

Nagios XI - Upgrade errors - root.crontab.orig: cannot overwrite existing file

Problem Description

When upgrading Nagios XI, the upgrade may fail with the error:

The following error message is produced:

root.crontab.orig: cannot overwrite existing file    

 

This problem generally occurs when there are leftover files from previous upgrades.

 

Resolving The Problem

This problem can be eliminated by running the following command:

cat /dev/null > /tmp/nagiosxi/uninstall-crontab-root

After this you can proceed to run the upgrade script again.

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

1 (2)
Article Rating (2 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Nagios XI - SourceGuardian Errors 2009R1.2C
Viewed 6291 times since Tue, Feb 2, 2016
Nagios XI - ERROR: unable to open include file: conf.d/*.cfg
Viewed 11417 times since Sun, May 29, 2016
Slack Notifications Stopped Working
Viewed 6653 times since Wed, Mar 18, 2020
Nagios XI - Disabling Database UTF8 Connectivity
Viewed 7137 times since Thu, Mar 8, 2018
VMWare checks timing out or slow
Viewed 5836 times since Fri, Feb 11, 2022
Nagios XI - Unable to Delete Host
Viewed 27589 times since Tue, Dec 16, 2014
Nagios XI - MK Livestatus Problems With Mod-Gearman
Viewed 7983 times since Thu, Feb 25, 2016
Nagios XI - ICMP and Ping Checks Stopped Graphing
Viewed 17247 times since Mon, Jan 25, 2016
Nagios XI - Last Check Time Not Updating
Viewed 27719 times since Tue, Jan 6, 2015
Active Directory / LDAP - Troubleshooting Authentication Integration
Viewed 23943 times since Mon, Jun 26, 2017