Home » Categories » Products » Nagios XI » Troubleshooting » Common Problems

Nagios XI - HTTP 500 Error / White Screen After Login

Problem Description

After upgrading to Nagios XI 5.x, when you login you are presented with a white screen or a 500 error.

 

Resolving The Problem

In Nagios XI 5, a new LDAP component was added and is intended to replace the original Active Directory component.

In some circumstances,  after upgrading the old Active Directory component causes the white screen / 500 error to appear.

To resolve the problem you need to delete the old Active Directory component.

Establish a ssh session to your XI server and execute the following:

rm -rf /usr/local/nagiosxi/html/includes/components/active_directory

 

Once you have deleted the old component you should be able to login.

Note: you will need to login as the nagiosadmin user as the new LDAP component will need to be configured. If you have forgotten the password to the nagiosadmin user please follow this guide:

Documentation - Resetting The nagiosadmin Password

 

To configure the new LDAP component please refer to this guide:

Documentation - How to Authenticate and Import Users with Active Directory

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/

0 (0)
Article Rating (No Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Nagios XI - WMI Authentication Problems
Viewed 791 times since Thu, Feb 25, 2016
Nagios XI - STRICT_TRANS_TABLES
Viewed 551 times since Thu, Nov 16, 2017
Nagios XI - Warning: Duplicate definition found for contact ’xi_default_contact’
Viewed 422 times since Tue, Jan 26, 2016
Web Browser Reports 330 Error Content Encoding
Viewed 424 times since Tue, Mar 7, 2017
Nagios XI - How To Use CA Certificates With check_ldaps Plugin
Viewed 626 times since Tue, Jul 26, 2016
Nagios XI - Downloading A System Profile
Viewed 380 times since Wed, Jul 19, 2017
Nagios XI - Missing localhost Alerts
Viewed 804 times since Sun, Nov 5, 2017
Nagios XI - 2014 Upgrade Issue - CONFIG ERROR
Viewed 370 times since Mon, Jan 25, 2016
Nagios Core - Nagios did not exit in a timely manner
Viewed 564 times since Wed, Jan 27, 2016
Nagios XI - Issues with mod_gearman and Performance Data Newlines: "\n"
Viewed 299 times since Tue, Feb 2, 2016