THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Products » Nagios XI » Troubleshooting » Common Problems

Nagios XI - Installing XI Fails To Install Dependency pymssql

Problem Description

When trying to install Nagios XI it fails with the following error:

--> Processing Dependency: pymssql for package: nagiosxi-deps-2012r2.9-1.noarch
--> Finished Dependency Resolution
Error: Package: nagiosxi-deps-2012r2.9-1.noarch (/nagiosxi-deps-2012r2.9-1.noarch)
           Requires: pymssql
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
RESULT=1

===================
INSTALLATION ERROR!
===================
Installation step failed - exiting.
Check for error messages in the install log (install.log).

If you require assistance in resolving the issue, please include install.log
in your communications with Nagios XI technical support.

The script that failed was: './1-prereqs'

 

Some of the original packages are not available through the standard repositories any more. To resolve the problem you need to add the Nagios Repository to the yum package manager.

 

 

Add Nagios Repository

There are different steps depending on your operating system, please refer to the following website for specific instructions:

Nagios Repositories

 

Once making these changes you will be able to re-run the fullinstall script to install Nagios XI.

 

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

2 (4)
Article Rating (4 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Nagios XI - Error while converting SVG
Viewed 6446 times since Thu, Aug 3, 2017
Nagios XI - Bandwidth Graphs Showing 0Mb/s in Non-English Systems
Viewed 9909 times since Fri, Dec 19, 2014
Nagios XI - NSP: Sorry Dave, I can’t let you do that
Viewed 25572 times since Tue, Jan 27, 2015
Nagios XI - MSSQL Query Wizard - Invalid characters in the username
Viewed 7437 times since Thu, Aug 3, 2017
ERROR: Please add the ’Optional’ channel to your Red Hat systems subscriptions
Viewed 30718 times since Tue, Jan 26, 2016
Nagios XI - CentOS 6 Installation Problems XI 2011R1.7 2011R1.8
Viewed 6816 times since Tue, Feb 2, 2016
Nagios XI - Ajaxterm Installation Aborted
Viewed 6030 times since Tue, Jan 26, 2016
Nagios XI - HTTP 500 Error / White Screen After Login
Viewed 8990 times since Mon, Feb 29, 2016
Nagios XI - ERROR: unable to open include file: /etc/mrtg/conf.d/xxxxxxx.cfg
Viewed 10994 times since Wed, Jun 1, 2016
OpenSSL causes issue with check_nrpe plugin with NSClient++
Viewed 14923 times since Fri, Apr 30, 2021