THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Multiple Categories

Nagios XI - SNMP MIB Upload Problems

Overview

This KB article provides solutions to issues that can arise when uploading SNMP MIB files.

 

 

Permissions

Some problems are caused by incorrect permissions on the SNMP MIB files.

If you receive one of these errors:

failed to convert to snmptt mib

MIB could not be installed - directory permissions may be incorrect.

 

Execute the following commands to reset the permissions and ownership:

chmod -R ug+rw /usr/share/snmp/mibs
chown -R root:nagios /usr/share/snmp/mibs

 

After executing those commands you should be able to upload the MIB file that previously did not work.

 

 

Modules Missing

MIBs can require modules that are defined in other MIBs. If you have uploaded a MIB to Nagios XI and the required modules are missing, you might notice some warnings when executing Net-SNMP commands in a terminal session.

For example, after uploading the MIB CISCO-IMAGE-MIB.my file you receive these warnings when using the snmpwalk command:

MIB search path: /root/.snmp/mibs:/usr/share/snmp/mibs
Cannot find module (CISCO-SMI): At line 24 in /usr/share/snmp/mibs/CISCO-IMAGE-MIB.my
Did not find 'ciscoMgmt' in module #-1 (/usr/share/snmp/mibs/CISCO-IMAGE-MIB.my)
Unlinked OID in CISCO-IMAGE-MIB: ciscoImageMIB ::= { ciscoMgmt 25 }
Undefined identifier: ciscoMgmt near line 27 of /usr/share/snmp/mibs/CISCO-IMAGE-MIB.my

 

In the error above the CISCO-SMI module appears to be missing. After uploading the MIB CISCO-SMI.my file you will not receive the warnings.

The explanation is that the Net-SNMP commands look at all the MIB files in the /usr/share/snmp/mibs/ folder when executing. The commands will display warnings if the modules are missing. You don't often see these warnings in the Nagios XI interface as this output is hidden, you commonly only see the warnings when in a terminal session.

 

It's worth mentioning that the filename "CISCO-SMI.my" is not how Net-SNMP knows that the the module is located in this file. This line in the file defines it:

CISCO-SMI DEFINITIONS ::= BEGIN

The fact that the file is named "CISCO-SMI.my" is irrelevant, however Cisco have made it easy by keeping the filename the same as the module definition name.

 

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

1.83 (6)
Article Rating (6 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Backups are not being generated due to tar creation errors
Viewed 5868 times since Thu, Feb 27, 2020
Nagios XI - ICMP and Ping Checks Stopped Graphing
Viewed 17247 times since Mon, Jan 25, 2016
Nagios XI - Problems Using Nagios XI With Proxies
Viewed 17572 times since Mon, Jan 25, 2016
SSL Certificate does not validate properly
Viewed 7772 times since Wed, Jan 20, 2021
Nagios XI - Optimizing The PHP Settings File
Viewed 72870 times since Thu, Jul 13, 2017
Nagios XI - Event Data Is Stale
Viewed 7904 times since Wed, Jan 27, 2016
Nagios XI - mysql_error out of range value for column
Viewed 9746 times since Tue, Aug 14, 2018
Nagios XI - Warning: Duplicate definition found for contact ’xi_default_contact’
Viewed 9704 times since Tue, Jan 26, 2016
Nagios XI - Hosts Pending/Gray
Viewed 14336 times since Tue, Jan 6, 2015
Nagios XI - STRICT_TRANS_TABLES
Viewed 11436 times since Thu, Nov 16, 2017