THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Products » Nagios XI » Troubleshooting » Common Problems

Nagios XI - Scheduled Downtime Not Working

Problem Description

When you attempt to scheduled downtime for a host or service the downtime never appears despite being informed it was successfully added.

In addition to this when you navigate to Home > Incident Management > Scheduled Downtime there are no entries.

This problem can be caused by the Nagios XI server being unable to resolve "localhost".

 

 

Diagnosing The Problem

Open an SSH session to your Nagios XI server and execute the following commands:

tail -f /var/log/httpd/error_log

 

Now go into the XI interface and attempt to schedule downtime for a host or service.

You receive output similar to the following:

[Tue Oct 11 13:49:55 2016] [error] [client 10.25.254.50] Couldn't resolve host 'localhost', referer: http://10.25.5.12/nagiosxi/includes/components/xicore/downtime.php?cmd=schedule&type=host
[Tue Oct 11 13:49:55 2016] [error] [client 10.25.254.50] Couldn't resolve host 'localhost', referer: http://10.25.5.12/nagiosxi/includes/components/xicore/downtime.php

 

You can see that the log file is complaining that it cannot resolve localhost.

If you execute the following command you can see the contents of the /etc/hosts file:

cat /etc/hosts

 

Here is the output:

127.0.0.1    localhost.localdomain    localhost.localdomain    localhost4    localhost4.localdomain4        xi-c6x-x64
::1 localhost.localdomain localhost.localdomain localhost6 localhost6.localdomain6 xi-c6x-x64

 

If you look at the output you can see that there are no "localhost" entries, there are similar entries but not one for "localhost".

 

 

Resolving The Problem

Edit your /etc/hosts file and make sure there are localhost entries. For example:

127.0.0.1    localhost.localdomain    localhost.localdomain    localhost4    localhost4.localdomain4    localhost    xi-c6x-x64
::1 localhost.localdomain localhost.localdomain localhost6 localhost6.localdomain6 localhost xi-c6x-x64

 

The last step is to restart the Apache service using one of the commands below:

 

RHEL | CentOS Stream | Oracle Linux 

systemctl restart httpd.service

 

Debian | Ubuntu 

systemctl restart apache2.service

 

 

Now go and schedule downtime, your problem should be resolved.

 

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

1 (2)
Article Rating (2 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Nagios XI - Migrate Performance Data
Viewed 16123 times since Tue, Jan 26, 2016
Nagios XI - Login Screen Keeps Redirecting To Itself
Viewed 9230 times since Wed, Jan 27, 2016
Nagios XI - SNMP MIB Upload Problems
Viewed 12212 times since Mon, Apr 10, 2017
Nagios XI - MK Livestatus Problems With Mod-Gearman
Viewed 7983 times since Thu, Feb 25, 2016
Nagios XI - ICMP and Ping Checks Stopped Graphing
Viewed 17247 times since Mon, Jan 25, 2016
Turning Off PHP Notices and Deprecated Messages
Viewed 6726 times since Wed, Oct 20, 2021
Nagios XI - Scheduled Backups No Longer Working
Viewed 11029 times since Fri, Jun 3, 2016
Nagios XI - Display All Scheduled Reports
Viewed 7068 times since Wed, Oct 12, 2016
Nagios XI - Common Upgrade Failures And Solutions
Viewed 17283 times since Thu, Jun 29, 2017
Nagios XI - Unable to Delete Host
Viewed 27589 times since Tue, Dec 16, 2014