THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Products » Nagios XI » Troubleshooting » Common Problems

Nagios XI - Hosts Pending/Gray

Problem Description

Your host objects (or services) are in a Pending state and they appear gray in color.

 

Explanation

This problem can occur when the host or service object does not have a check command assigned to it.

 

Resolving The Problem

Add a valid check command to the host or service object.

This example will focus on defining a check command on the localhost host object.

From the Configure menu click  Core Configuration Manager (CCM)

Under Monitoring click Hosts

Click the host localhost

Select the Check command check_xi_host_ping

Populate the argument fields with the following values:

$ARG1$ = 3000.0

$ARG2$ = 80%

$ARG3$ = 5000.0

$ARG4$ = 100%

Click Save

Click Apply Configuration

 

Now the local host will have a valid check to execute.

 

 

Other Problems

This issue can occur as a side affect of other problems on the Nagios XI server. The following is a summary of those issues and links to supporting documentation.

 

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

1 (2)
Article Rating (2 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Nagios XI - Event Data Is Stale
Viewed 7904 times since Wed, Jan 27, 2016
Nagios XI - Optimizing The PHP Settings File
Viewed 72870 times since Thu, Jul 13, 2017
PHPMailer - Troubleshooting Using Debug Logging
Viewed 42376 times since Tue, Aug 14, 2018
Nagios XI - Resolving "Cannot connect to database" Error - Core Config Manager
Viewed 10770 times since Mon, Jan 25, 2016
Nagios XI - Installing Latest SourceGuardian Loaders
Viewed 10718 times since Mon, Jun 18, 2018
Nagios XI - Warning: Duplicate definition found for contact ’xi_default_contact’
Viewed 9704 times since Tue, Jan 26, 2016
Nagios XI - ERROR: PostgresQL not running - exiting
Viewed 7036 times since Tue, Jan 26, 2016
Nagios XI - ERROR: unable to open include file: conf.d/*.cfg
Viewed 11417 times since Sun, May 29, 2016
Nagios XI - Debugging Bandwidth Performance Graphs
Viewed 19664 times since Tue, Jan 27, 2015
Nagios XI - Best Practices - NWC15
Viewed 10816 times since Thu, Feb 4, 2016