THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Products » Nagios XI » Troubleshooting » Common Problems

Nagios XI - Warning: Duplicate definition found for contact ’xi_default_contact’

Problem Description

When you try to apply configuration, you see an error, similar to this one:

Warning: Duplicate definition found for contact 'xi_default_contact'
(config file '/usr/local/nagios/etc/contacts.cfg', starting on line 79)
Error: Could not add object property in file '/usr/local/nagios/etc/contacts.cfg' on line 80.
Error processing object config files!

 

This usually happens if you import the "static" directory config files in Nagios XI.

 

Resolving The Problem

You can resolve this by running the following command and then applying configuration:

Type:

curl -s http://assets.nagios.com/downloads/nagiosxi/scripts/fix_static_import| mysql -pnagiosxi nagiosql

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

1 (6)
Article Rating (6 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Nagios XI - Installing Latest SourceGuardian Loaders
Viewed 10719 times since Mon, Jun 18, 2018
Nagios XI - Running Out Of Disk Space On The Nagios XI VM
Viewed 28581 times since Tue, Jan 27, 2015
Nagios XI - Configuration Applies, No Changes Take Place
Viewed 10981 times since Tue, Jan 27, 2015
Nagios XI - Problems Using Nagios XI With Proxies
Viewed 17572 times since Mon, Jan 25, 2016
Nagios XI - mysql_error out of range value for column
Viewed 9746 times since Tue, Aug 14, 2018
Nagios XI - Reset Upgrade Status In Web Interface
Viewed 14571 times since Tue, May 7, 2019
Nagios XI - Some BPI Checks Show "Unknown BPI Group Index" After Upgrade
Viewed 6107 times since Wed, Sep 18, 2019
Nagios XI - Problems with $ Signs in the Check Command
Viewed 12010 times since Tue, Jan 26, 2016
Disabling Port 113 IDENT Requests
Viewed 8385 times since Tue, Mar 12, 2019
Nagios XI - Defining Global Environment Variables
Viewed 13414 times since Thu, Mar 17, 2016