THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Products » Nagios XI » Troubleshooting » Common Problems

Nagios XI - NSP: Sorry Dave, I can’t let you do that

Overview

Session protection was added to 2009R1.2C to prevent CSRF attacks. This code to do this caused some users to see this error. The problem was due to the user's browser caching older versions of the XI javascript code. In order to clear the cache and prevent this from happening, you need to clear your browser's cache. This is typically done (in Firefox) by holding down the shift key and clicking reload.

 

Another possible cause is that the server's time is out of sync with that of the browser. A detailed document that explains all the settings performed can be found here:

Documentation - Changing The System Time

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

1 (4)
Article Rating (4 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Nagios XI - Can’t Log Into The Web Interface
Viewed 69453 times since Tue, Jan 27, 2015
Nagios XI - ERROR: unable to open include file: conf.d/*.cfg
Viewed 11418 times since Sun, May 29, 2016
Nagios XI - Scheduled Downtime Not Working
Viewed 9935 times since Mon, Oct 10, 2016
Nagios Core - Failed to register iobroker
Viewed 9302 times since Wed, Sep 20, 2017
Nagios XI - Configuration Verification Failed
Viewed 23137 times since Mon, Jan 25, 2016
NRPE - Agent and Plugin Explained
Viewed 79236 times since Fri, Jul 14, 2017
API changes in Nagios XI 5.7
Viewed 5883 times since Tue, Feb 23, 2021
VMWare checks timing out or slow
Viewed 5836 times since Fri, Feb 11, 2022
Nagios XI - Running Out Of Disk Space On The Nagios XI VM
Viewed 28581 times since Tue, Jan 27, 2015
Nagios XI - Apply Configuration Never Completes
Viewed 26095 times since Tue, Jan 27, 2015