THIS KNOWLEDGE BASE HAS BEEN ARCHIVED AND IS NO LONGER BEING UPDATED
Please visit library.nagios.com/docs for the latest and most up-to-date documentation.
Home » Categories » Products » Nagios XI » Troubleshooting » Common Problems

Nagios XI - Ajaxterm Installation Aborted

Problem Description

Nagios XI 2012 and late versions of 2011 set up apache to be able to utilize the Ajaxterm subcomponent.

This component requires a modification to the /etc/httpd/conf.d/ssl.conf file, and adds some proxy information needed specifically for ajaxterm.

If apache failed to restart after making these modifications, the previous configuration gets rolled back in order to keep apache running the the system usable.

 

Resolving The Problem

The bad configuration that the fullinstall/upgrade script attempted to apply is saved to /etc/httpd/conf.d/ajaxterm.fail.

This file can be debugged and once fixed, can replace the existing ssl.conf file in order to utilize Ajaxterm.

Note: Remove the /etc/httpd/conf.d/ajaxterm.fail file once the issue is resolved to avoid the error message in the UI.

 

Final Thoughts

For any support related questions please visit the Nagios Support Forums at:

http://support.nagios.com/forum/



Special Offer For Knowledgebase Visitors! Get a huge discount on Nagios Log Server by clicking below.

Get 60% Off Nagios Log Server!

Did you know? Nagios provides complete monitoring of: Windows, Linux, UNIX, Servers, Websites, SNMP, DHCP, DNS, Email, Storage, Files, Apache, IIS, EC2, and more!

1 (4)
Article Rating (4 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Nagios XI - ERROR: unable to open include file: conf.d/*.cfg
Viewed 11417 times since Sun, May 29, 2016
Upgrading to NDO 3 after having been downgraded in newer versions of Nagios XI
Viewed 6258 times since Fri, Jan 15, 2021
Nagios XI - Empty Screen for Wizard, Component, Dashlet
Viewed 10289 times since Wed, Jan 27, 2016
Nagios XI - STRICT_TRANS_TABLES
Viewed 11435 times since Thu, Nov 16, 2017
Nagios XI - MK Livestatus Problems With Mod-Gearman
Viewed 7983 times since Thu, Feb 25, 2016
Nagios XI - Windows Memory Usage - Physical
Viewed 21309 times since Tue, Jan 26, 2016
Nagios XI - SourceGuardian Errors 2009R1.2C
Viewed 6291 times since Tue, Feb 2, 2016
Pages Not Displaying Correctly
Viewed 10897 times since Mon, Jan 25, 2016
Nagios XI - Problems with $ Signs in the Check Command
Viewed 12010 times since Tue, Jan 26, 2016
CCM says unapplied changes exist, but none listed
Viewed 8154 times since Mon, Feb 27, 2017